Remove large Watermark/overlay in PDF

I’m trying to make a PDF but somehow I ended up with it producing these huge green letters across the finished product. I don’t see them anywhere in the draw program, only when I export it to PDF and open it with another program.
Help! How do I get rid of these huge green letters?

Choose menu File - Export as - Export as PDF… - General tab, and uncheck Sign with watermark before pressing Export.

Edit your question if you want to add more information; also can comment an answer (Add Answer is is reserved for solutions).

Check the mark (Correct answer mark) to the left of the answer that solves your question.