Removing a pesky ghost version of Libreoffice 4


Here’s my situation. I have been using Libreoffice for years successfully, and have a 2013-era Macbook which I originally got for work. I have two user profiles on it: my personal one, and my school one. The personal one has no issues whatsoever; I can double-click on documents and they’ll launch in LO5 without a problem, and I can launch LO5 from the Dock and it’ll happily bounce and then open. But on my School profile, it’s a different story. Double-clicking on a document of any type (.doc, .docx, etc) has a chance of opening it in LibreOffice 4, which pops up as a separate icon in the dock. If I try to open LO5 from the dock, there’s about a 50/50 chance that the icon will bounce once and then go into “Application not responding” mode until I force quit it. I have absolutely no idea how or why this is happening; I even created a brand new School profile to see if that would help, but the issue followed me there. I have looked high and low for evidence of LO4 on my computer. Obviously it has to be there somewhere but I can’t find it to delete it specifically, hence why I’ve started calling it the ghost version of Libreoffice.

Every so often I will open a document and get an error message that says something to the effect of “Warning: Your settings are in use at another location”, except “another location” is always my School profile. I’m sorry that I can’t recreate the wording exactly, but this warning, like everything else, pops up pretty much at random.

Here is a list of things I have already done in hopes of fixing this issue:

  • I have completely deleted Libreoffice from the computer and done a clean reinstall, including restarting the computer in between. I have done this twice, and I even did it from the user profile where I first installed the program, just to be safe. No dice.
  • I deleted and created a new user profile, as per these instructions: No change.
  • I updated LibreOffice to the latest stable version of LO5. I thought this had solved the problem, but as of today it’s back.
  • I scrounged Google and these forums trying every possible wording of this issue I can think of. No one seems to have had this exact problem that I can find so far.
  • I tried to change the default program from Libreoffice 4.3.6002 to LO5. I’ve done this more times than I can count. It has never, ever worked.
  • I have tried to delete all instances of LO4 using the Terminal but the only instructions I could find were for Ubuntu, so they didn’t work on my Mac. While I’m familiar with Terminal commands, I know enough to know that I’d rather not muck around with sudo and purge commands without direction.

I’m out of ideas and it’s getting extremely frustrating to not be able to launch word documents reliably. I’m bewildered as to why this only happens on one user profile but not on the other. If anyone can help, please, let me know.