Removing hyperlink from part of a text line in Writer

I give up. I added a hyperlink to a line of text. I then added some text immediately after that and it became part of the hyperlink. I don’t want it to be included in the hyperlink. If I select that part of the link and right-click, there’s no option to remove hyperlink. With that text still selected, Hyperlink in the Edit menu is grayed out. If I copy the text, delete it, then past as unformatted text, it still gets attached to the hyperlink. Clear formatting doesn’t help, either.
Since the hyperlink text is the last entry in a table cell, anything entered after it in the same cell becomes attached to the hyperlink. There’s no way to move past the end of the hyper link or turn it off to enter something else.
For example, if I have a superscript at the end of a line, I can turn off the superscript before adding more text. How can I do that for a hyperlink?

I’m using LibreWriter 7.4.3 on Windows 10 64-bit. Same behavior with earlier versions of

Only if I save as .docx can I get some of the behaviour you describe; always work in native format, .odt. If you need to share with someone who can’t read .odt (Microsoft says it can) then Save a Copy as .docx.

The added part is not hyperlink, it is just a character style so select it backwards starting from the end of the text back to the end of the actual hyperlink. Open the Sidebar, select Styles and then Character Styles and double-click No Character Style

Cheers, Al

Thanks for the information. It was originally a Word document so that must be the issue. I’ll save it as an odt file and see if it works.