Rendering errors, no top menu, no doc icon on OSX 10.11.6

Hi everyone. Apologies, I don’t quite have the right words for what is going on here, but since this morning while trying to open a CSV file in Calc, I’ve been having some serious issues. The document renders as a jumbled mess when I interact with it. There is no “top menu” bar (e.g. where one would expect to see file, edit, etc) and there is no doc icon. Spellcheck is gone but, really, when the document renders as a jumble the moment you try to edit it, spell check isn’t the first concern. The problems are there for all files, including files that were previously fine.

I’ve reinstalled LibreOffice but that hasn’t fixed the problem. Thoughts anyone?

You can see the rendering errors on this twitter post:

Okay more detail. When I try top open the LibreOffice application, it bounces a bit in the dock and disappears. When I open it by opening the CSV file, the file opens but no doc icon and no menu bar.

I’ve tried three different version of LibreOffice, same problem on all of them. I’ve deleted my user profile. No help. It’s all really weird. Help? Again, suffering here from a lack of vocab.

Even stranger. I tried installing OpenOffice because, you know, work to do…and it exhibited a similar issue. Open app, bounce in doc a bit, disappear. Unlike LibreOffice it would indicate that there was a crash.

Some sort of shared corrupted library that I can’t find? These are the only two applications that are not working properly on the Mac

Ok I upgraded to Sierra…and this is still happening. What the heck? Anyone? Or can anyone tell me how to remove EVERYTHING for a total reinstall (although I thought i already did it).