Repeat command (Shift+Ctrl+Y) disabled

I often encounter a situation when the repeat command in the menu bar (Shift+Ctrl+Y) is grayed out. The latest is deleting a row in a table in Writer. I put a cursor in a table row and select Table | Delete | Rows. After that the Edit | Repeat command is disabled. Shouldn’t it be enabled for almost all actions?

I have LibreOffice