Replace text malfunctioning?

I’m typing up notes and set “def.*” as “definition”, per here

and while it works for “def” and “defs” to “definition” and “definitions”, “def:” always either creates “definitioninition:” (with the colon) or “definition” (the plain word, with no colon).

I guess I don’t actually have a clear question here. There is something wrong and I would like to fix it. If there’s no simple solution, I would like to know so that I can message the appropriate entity about a bug.

Hi - I reproduce the problem

The “:” is a word separator that triggers the auto-correction.
def: is replaced by definition:

Definition: is also replaced because it matches the regular expression def.*

The problem does not arise in French for example because of inserting a non-breaking space between the word and:

I made a test in Libo on an XP machine

I set Tools > AutoCorrect > Replace

def = definition
defs = definitions

Typing def or defs and hitting ENTER gives above listed results => correct
Typing def. or defs. hitting ENTER gives above results with an " . " at the end => correct.

What settings are you using?
Which LibO version?
Which OS?


Thank you. I figured it just worked that way, but I was hoping there was some way to stop it.

Edit: whoops, can’t make two comments.


Thank you.

I didn’t set “def” or “defs”, I set"def.*" and "defs.*", which allows the shortcut to function even when it is attached to suffixes.

I’m using in Windows 8.

I think Pierre got it. Hitting space after the colon just triggers the shortcut again, and it applies to the “def” in the beginning of the word.