Report template stops working after its source query is changed

I have spent quite a bit of time using Base to make a nice invoicing app using a REPORT to make the invoices. There are various tables in underlying database (Firebird), which are combined using a specific QUERY as basis for the report. Everything was working well until I decided to modify one of the tables JOINED in the query (adding a couple of columns and removing a couple of other columns in the said table). The modified query works as expected when run as a regular SQL query.

The problem is that, now, when the report is run, all the fields in the generated report are BLANK (except for just a single one, oddly). I have tried ‘reconnecting’ each data field in the report template (using the report editor wich seems to be connecting to a stored query with the same name). When I do this, each data-field in the report template shows the expected field/column name (as per the query already setup). I have also tried deleting various data-fields in the report template, and then re-creating them from scratch using the report navigator. Neither of these procedures work. (i.e. when the report is ‘run’, where there should be field values, as before, there are now just blank spaces)

I have noticed that the order of field information between the two versions of the REPORT-QUERY (when run in the QUERIES window) is somewhat different (and, as I already said, there are some additional fields present in the revised query also.

My thinking, so far, is that the report template somehow links the report-query columns with some additional internal representation of this same information within the report template, and that this has been put ‘out-of sync’ by simpling changing the report query (SQL). Any ideas on this problem? I don’t really want to have to re-create the report template from scratch every time I change the report query. To me, it looks like a bug.


Using LO v on Ubuntu 20.04.1 Mate, I have a report which includes a join and union. Did some modifications but could not duplicate your problem. Did try this with Firebird embedded.

Can only recommend either posting a sample which produced this problem or report it as a bug.