Report wizard doesn't open in Base

I tried to open the Wizard to Create Report. The first time, it opened a window that said I needed Java. I downloaded and successfully installed Java. I closed all browsers and LO and restarted the computer. When I try to open the report Wizard now, nothing happens. There is no error message, just nothing. I am working on a new Lenovo AIO (just set up on 12/31/21). Do I need something else? I feel like LO isn’t working properly since I had a problem using mail-merge. I submitted a question about that problem, but I don’t know how to link that with this problem. If anyone has any ideas, I would love to fix this. Thanks in advance for your help.

How to install Java (JRE/JDK) so that LibreOffice could use it?

I followed this download for the Java install.

I had read the instructions in your link before installing, so I think I have the correct version.

Does LibreOffice recognize the Java installation? (Option → LibreOffice → Advanced → Java Options)

When seeing the screenshot: You installed an old Java version. Some functions for LO 7.* will only be available with JRE >= 9

Forget all this when you could connect to an internal database. You have created a table for the data you will need in report - then it should work.

There are 2 Tasks in Report pane: Create Report in Design View… and Use Wizard to create Report…. Is there any reaction if you try to create report in design view?

This is the screen shot for the java installation. It looks like nothing is recognized. In selecting the create reports I get a report screen and a small window with columns from the first sheet. I don’t know how to use it and that was what sent me to try the report wizard. Nothing at all happens when I click on Use the Wizard.

I would have to read the documentation to learn how to use the Create Report in Design View. If you think I need to download a later version of java, I will try to do that. Otherwise, I can add a new sheet and copy the data I need and create a report from that. I will look into the create a report if I can’t get the wizard to work.

Thanks for your help.

I would download a newer JRE. Have installed OpenJDK 11 here on a Linux system.

You have read the instructions, so I think it isn’t the main problem 32bit or 64bit.

If LibreOffice doesn’t recognize JRE you couldn’t use the internal HSQLDB and also couldn’t use any wizard, which is part of Base. Special the ReportBuilder couldn’t be used. Most of the code of ReportBuilder is written in Java.

But: How do you connect to a database at this moment? Please show a screenshot of your database window with opened table pane.

@LindaPro , I think from your screenshot that you are using Windows as your operating system. Here is a detailed description for Windows:
Install the correct JRE

And this is the Java-Link:

Scroll down.
Use the Offline Version for Download.
Install Java.

The version registered with me:

I will install a new JRE based on the instructions from Hrbrgr. In the meantime, here is the screenshot of one of the sheets in the database.

I started to download this and realized that I probably needed the English version. After I tried to set Java to English, it looks like the same download I already did. Would you be able to repeat these instructions with the English version? Thanks for your help.

I checked in my Setting and it appears that Java 8 Update 321, Version 8.0.3210.7 is installed on may computer as of 2/24/22. When I look at the Java Options in Libre Office, there is still nothing that says Oracle.

When I try to use the create form or create report wizard, I don’t get a response from LO at all, no error message, nothing.

Is there anything else I need to do to get this to work?

Thanks for your help.

Have you checked, if your LibreOffice is 32bit/x86 or 64bit?

Yes, it is 64-bit and was recently downloaded because I had to replace my computer on 12/31/2021. Thanks for the suggestion.

I wanted to update this and am not sure if I am in the correct place. I removed the program Java and reinstalled. Now when I look at the advanced screen it shows the Oracle info and I am able to use the report wizard. I am not sure what I did wrong on the first install, but Java wasn’t being recognized in LO. I’d like to thank everyone for the help in trying to resolve this matter.