Reports are not saving on Libreoffice Base

Version: (X86_64) / LibreOffice Community
Build ID: cdeefe45c17511d326101eed8008ac4092f278a9
CPU threads: 4; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: pt-BR (pt_BR.UTF-8); UI: pt-BR
Calc: threaded

Hey everyone, I’m on the final lap of creating my database, now I’m creating some more reports. Unfortunately I’m going through some issues while doing it. My reports are kinda buggy, let me explain the issue.

I simply cannot save the report, I tried a lot, I run it, it’s perfect, the way I want it to look, but when I try to save it simply doesnt work, even though the Save Button is highlighted it still highlighted after I click it, just ignoring my click, and if I give up and close it, when I run the report again, it goes back to what it was before the changes i’ve made.

Does this happen with anyone else? Have anyone ever heard about this issue?

Thanks for the help.

Never heard about such a problem - but there are many stability-problems with ReportBuilder.

  1. Try to start LO in save mode and save a report.
  2. Try to start LO by SAL_USE_VCLPLUGIN=gen ./soffice (in konsole of program folder of LO) to exclude it is a gtk3-bug.

When I use it this way it works properly, I can edit and save and everything stays as I need.

When I run LO from the folder /usr/lib/libreoffice/program/ using the SAL_USE_VCLPLUGIN=gen ./soffice command I get this version of the program:
Build ID: 1:6.4.7-0ubuntu0.20.04.9
CPU threads: 4; OS: Linux 5.15; UI render: default; VCL: x11;
Locale: pt-BR (pt_BR.UTF-8); UI-Language: en-US
Calc: threaded

If it runs in save node: rename user directory of LO home/unser/.config/libreoffice/4 to home/unser/.config/libreoffice/4old. It will be created new.

If you start a different version of LO in /usr/lib/libreoffice/program/ your current used version isn’t installed on this place. You are using LO directly from LO, but the version you started is a very old version of Ubuntu.