Reset document properties on save

To avoid including information such as number of revisions and total editing time, I can simply proceed to File > Properties, open the General tab, and clear the Apply user data check box.

Of course, instead of clearing this check box for each new document, it is much better to disable it for the template (I use a custom one).

However, as I discovered, if you disable it for the template, it also makes impossible for Writer to detect if the template has been changed when you open documents based on it.

I have reported it as a bug: https://bugs.documentfoundation.org/show_bug.cgi?id=145047, but nobody answered or confirmed it yet.

Is there a workaround?

Template change detection works only if the template is integrated with LO. If you create a document by double-clicking on the template icon, this doesn’t link the new document with the template. Then no change can be detected.

By integration, I mean your template has been installed in the internal LO library through File>Template>Save as Template. New documents are created with File>New>Templates.

Are you sure user data is the correct criterion for removing this info (IMHO, it is rather innocuous)? If your goal is some privacy, you’b better erase user data in Tools>Options. I do so on “public” documents to protect my details.

PS: Your bug report has next to no value: you give no procedure to reproduce the problem. Also, it is certainly good to attach both a template and a so-templated document. Developers’ time is rare and precious. Spare their time by providing everything needed to make a quick check.

The template is used correctly, I know how to use them.

If your goal is some privacy, you’b better erase user data in Tools >Options .

Each time? No, thanks.

Your bug report has next to no value: you give no procedure to reproduce the problem.

Actually I gave it. (And actually I have a second bugzilla profile with dozens of confirmed bugs.) And to be honest I cannot seriously take words about “valuable time” when we talk about software that is crashed at least one time a week or two even on very simple tasks and have dozens of critical bugs that are not fixed for years.

This is a community not too much liking the faint indications of arrogance found in some posts now and then. From my experience I would judge that absolution freehandedly is spent those having helped many times and having received the due credits for their engagement by users upvoting their postings.

Workarounds:

  • A slightly quicker way to clear the Apply user data check box would be to have the check box enabled in Edit document properties before saving in Tools > Options > Load/Save > General.
    The Properties dialogue opens automatically in General, you have only to clear the check box and OK, or dismiss the dialogue as appropriate for you document.

  • Instead, you could have a second installation of LibreOffice in which you have your templates for not including user data. That installation could have “Use data for document properties” check box unticked permanently in Tools > Options > LibreOffice > User Data. See https://wiki.documentfoundation.org/Installing_in_parallel/Windows for parallel installation

Another workaround avoiding parallel installation is to create another user account (this is what I do). Since user data is kept in user profile, you just configure Tools>Options in this second account with empty user data.

You have thus a user account for your own documents and another one for public documents.

Having two user accounts (for different jobs) does not prohibit document sharing. Again it is a matter of configuring permissions. Put both account under the same group and grand group write permission.


PS: considering the stability I have on my machines (yes plural and one of them is lagging several years having LO 5.x on it) even on very complex documents, I would rather look for problems in the OS.
From my experience, stability can be impacted by a large number of frames when they undergo heavy direct formatting (i.e. manually tuning their positions or attributes). Direct formatting may contribute to the issue but as you use templates, you probably style thoroughly your documents.