Result of setFormula() not recognised (solved)

The following line of code inserts a formula using the function COUNTIF into cell F43.


The formula is inserted in the cell exactly as expected, but the result in the spreadsheet is Err:508.
(I tried “”=1"", but the result is the same.)
I can manually copy and paste the formula from the formula bar back in to the formula bar and it then works correctly.
A similar expression using a SUM function in place of COUNTIF works correctly.
Is there some limitation on which functions can be used in setFormula? Or am I missing something?

When the sheet is copied from elsewhere, Calc seems to be deciding that the column F is all DATES. This may have something to do with problem, but does not entirely explain it. The problem reproduces in another column. Now there is a second less important question: why is Col F becoming DATES?


You have to use same separator as ToolsOptionsCalcFormulaSeparatorsFunction.

For example, with my french UI :


So, is it , for you?


Thank you so much, Pierre-Yves, the semi-colon has fixed it, although, yes, the separator IS defined as comma, so there is a bit of mystery there!
Strange also that you can get away with a comma separator when entering the formula manually.
(I’ve fixed the date problem)