"Return" character cuts off formula?

Ran into something while making a study sheet for one of my classes. The “return” character has some attribute (if that’s the correct term) that will cut off anything below a certain point on its line. Like so (the “2” in the fraction on the first line is cut off at the bottom):

I don’t think it’s a bug, just a default setting somewhere I can’t figure out where to change. And it’s not really a huge problem, because the work-around is easy: use tabs instead:

Still, I was wondering if there was a way to edit the behavior of the return so that the work-around isn’t necessary. Here are the settings I’ve got for this document (the spacing is the only change I’ve made from the default settings of Writer, at least on purpose):

Not sure if the version matters; in case it does, I’m running Version: (Build ID: 48d50dbfc06349262c9d50868e5c1f630a573ebd) on Windows 7 Home Premium SP1.

You are using ‘RETURN’ outside the formula. This will create a new paragraph of your text. You may also use Shift+RETURN to only force a line break.

It is the fixed line spacing that is causing your problem. Choose another setting.

If you need a fixed line spacing for specific parts of your text you should define and (where needed) apply different named paragraph styles and not rely on the ‘Default’ style.

(How to create a chance for the metric system? See this text. In LibreOffice the measurement unit can be chosen under ‘General’ > ‘Settings’ for any component of the software independently. Entering a value in the not preset unit will always be possible: 1 cm or 0.4" e.g.)