Run soffice command prompt /opt/libreoffice4.1/program/oosplash: error while loading shared libraries: cannot open shared object file: No such file or directory

My system is CentOS 6.4
Installed version is Libreoffice 4.1

When I installed successfully. Set the environment variable.

Now I run “soffice - help”.

An error message:
/ Opt/libreoffice4.1/program/oosplash: error while loading shared libraries: libX cannot open shared object file: No such file or directory

I want to install “libXinerama-1.1.2-2.el6.i686.rpm” to resolve. After installation is complete, now I’m a documents /uar/lib/, But I run “soffice - help”, This error message is displayed again. I do not have a solution. Please help.

Eager to solve. Please help.

Are you trying to run in headless mode? I would think that the run parms should either be soffice --help (to display help) or soffice file_to_be_opened to start up LO in GUI mode with splash screen.

OP: @andika

There’s libXinerama package in standard repo for both 32-bit and 64-bit OS that contains this file. I have no clue whether you can install both in 64-bit OS, however.

I want to pass command to convert files. So starting command mode.

Are either of these threads helpful? Convert files to PDF/A on command line, headless mode or Headless mode examples for socket and pipe methods. Both those seem to relate to using command mode.

How you solved this issue? I am having the same problem and not sure what is the fix.

Please help.

@sunnyr the error is usually an indication that the library in question cannot be found. This can be due to a variety of reasons but is sometimes the result of mixing 32bit and 64bit applications and libraries. All I can suggest is confirming that you have installed a version of LO that matches your system (and that the referenced libraries also match in this respect).