Saving a file on google drive does not work on version

Hi all,
I am testing wit h LibreOffice and not sure if it is a bug, or that i am doing something wrong…

I try to save a file in Google Drive using the new option “save file on external server”. In Google i have account and in Drive i attached the Libre office app… .So, i choose the right drive and Google Drive and try to save my file. It looks like it is written to Google drive, but i can not find it in Drive anywhere… Is it maybe because DRIve does not recognize Libreoffices’ .odt filter?

AN answer would be wonderful!

Thanks ,


Broken in The Document Foundation folks should save face and remove this “feature” until it actually works.

Build ID: 1:5.2.2~rc2-2
Debian Testing
still not working

I’ve been using it on LO v5.1.x & 5.2.x successfully on Xubuntu.

Version: on Debian Jessie
no go either…
i need this feature, though
it did ask for a PIN once, but my account wasn’t linked to a phone … and I received no email from google
i do get warning emails from google saying something is trying to access my account…

Similar problem here with and calc.
I can’t save or open a file from Google drive.
It doesn’t matter if it is a .ods or a microsoft extension.
Saving and opening on a ftp-server works fine.
Any idea what’s wrong?

regards Ger

This appears to have been broken for v5.1.0. Refer tdf#96174 for which a fix has been made for v5.1.1 and v5.2.0.

I tried today with LO on Windows 7 and my Google Drive.
After having received the Google verification code LO answers : specified device invalid.

When you go to Help you get an empty entry: “There is currently no text in this page”

If I understand well in 8 months since the last post nothing happened ?

I guess none from Libreoffice reads their proper forums.
But we are far better than the dreaded MS$, of course.

Works fine in 32 bits LO (and 5.2.3) on Windows 10 with all updates as per 7th November 2016. An extra password is required. Google will mail you every time you access it. Takes a little more time of course to open and save files.

However, I’d warn against directly working with files on Google Drive or any other cloud service, or even an USB memory stick. What if the connection fails and you lose your work? I’d say it’s much better to get the file from the cloud service and park it on your computer, edit the copy on the computer with Libre, save the edited version, if needed, on the computer, then move the edited version to Google Drive. A bit more work, but a lot safer as well.

HI, similar with , tried login , received my G-xxx Pin , but after entered , it said , not valid and won’t log me in and cannot save or retrieve files from Google Drive.

regards, kalmen

Same here. G-pin received twice (the same PIN), but not working (“invalid device”).
Version: (x64)
Build ID: 0312e1a284a7d50ca85a365c316c7abbf20a4d22
CPU Threads: 8; OS Version: Windows 6.1; UI Render: default;
Locale: it-IT (it_IT); Calc: group

Workaround: download document from GDrive on local HD, edit, sync again with GDrive. Let LibreOffice do LibreOffice and GoogleDrive do Google Drive. Safer, quicker, tested, working. Suggest removing GDrive support from LO altogether.

I’m now using LO and it is not possible for me to login to my Google Drive (GD). I’ve tried with 2FA and without, but no luck so far. Also, I’ve now 4 entries in the drop down box for the various attempts that are all called the same, but when choosing each of them, I immediately get a message general input/output error. How to get rid of these entries?