Saving edited files opened from a zip files with the portable version

Greetings, I like the software very much, and using the portable version on the go. However, when opening a file from a zip file (by dropping it in the LibreOffice main windows) and making some edits, the file isn’t properly saved, and the winrar interface does not show the “modify latest update?” question it is showing when using microsoft office… Any help?


You must ask WinRar, they must add special functionality for MS Office.

If I modify a docx file with Word 2010 from a zipped file and try to save it, I get a notice saying it is read-only if I try to Save.

If I do the same with LibreOffice, it offers to Save As in another location.

Windows 11 without WinRar installed.

BTW .ods and .docx files are zipped anyway, I presume you have a good reason to zip them again.

apparently the problem is related to the portable edition, when I’m opening the document with the installed software, it can save it properly.

Any advice?

No. It doesn’t seem to be a LibreOffice issue. It is a WinRAR function.

Or, don’t keep your documents in a zipped folder

Please provide more details: what is the exact version of your installed LibreOffice, and what is the exact version of the portable one.

I suspect that the problem is introduced ~lately (v.7.1.3+), in tdf#126742, with commit 2b4cd99d3360ccffb9829a02412824864d045753 “make Windows file handling more unx-like”. That might mean, that LibreOffice doesn’t hold lock on the opened file - something that archivers watch in order to detect temporary file changes.

You might then file a bug report.

I’m using the 7.5.4 portable version, and tried the same thing with the 7.4.7 one.

I tried numerous software - winrar, winzip, peazip, ISARC, even total commander, xyplorer, directory opus.

All show the same results, when opening it directly from the archive, it is opened in ms office (because LibreOffice is portable ill have to drag it in from the archive), when making changes and saving, the archive software will show this pop up “update modified files?”. when I edit it with the portable version OR the installed one, it just won’t show the dialogue and the file won’t be saved…

both the zip, and the docx file are encrypted with a password.

Please advise, I like your software very much, and would be very disappointed to not be able to use it…