Scan media fails

Starting with LibreOfffice 5.3.4 for me the scan function on longer works. Insert->Media->Scan->Select Source does not bring up a selection box so Request does not perform any function. LO version 5.2.6 for me is the last that works on Windows 7 - 64bit connecting to a Canon 9000F Mark II scanner in Writer. Is this a known issue?

After much version installing and removing it turns out the 64 bit version of LO will not work for me even though my OS is 64 bit. Although the latest version of LO in 32 bit has no issues so far. I can scan with Writer as I had before.

The CanoScan driver versions are supposed to be 64 bit as well.

The Canon Driver may be designed to operate with a 64 bit operating system, that doesn’t mean it will work with all 64 bit Office software. Unfortunately my Epson scanner fits in that category so will only work with 32 bit LibreOffice. The 32 bit version is unstable when I scan into LibreOffice. I haven’t found a work around yet, contacting Epson and LibreOffice hasn’t helped. Epson and LibreOffice blame each other for the miss match. OpenOffice only produce 32bit version so never had problem.

I’m having exactly same problem Windows10 64 bit and LibreOffice Version: (x64). Been looking round the web and here plenty asking the question why and how to fix but found no answers so far. Scan function works fine with OpenOffice so I don’t think its the scanners software which is an Epson Perfection V370. Only just installed LibreOffice and so far its better than OpenOffice except for this problem.
Just realised my scanner has no 64bit driver available so uninstalled LibreOffice and installed the 32bit version and it works fine with my 64bit Windows 10 and my scanner. The link for LibreOffice 32bit (86) version is here Download LibreOffice | LibreOffice - Free Office Suite - Based on OpenOffice - Compatible with Microsoft

Taking on board what dadto7 said I have uninstalled the 64 bit version installed the 32 bit version and so far the scan function and all other functions so far tried work fine

I tried LO version 6.0 in 64 bit which does not work either. But, the 32 bit version of 6.0 does scan my Canon CanoSscan 9000 Mark II. I love Libre Office so will try anything to stay with it although I wish the developers could get the 64 bit version to work.