SCIM dysfunctional on LibreOffice 5 Calc under Linux


I think that I have found a bug in LibreOffice 5.

I’ve been using SCIM in LibreOffice 4 on Linux for years with no problems, but LibreOffice 5 Calc does not work properly with SCIM. At first I was baffled by what was going on, but after much testing, I’ve identified what the problem is.

If I activate SCIM in LibreOffice Calc and begin typing, then everything is okay until I type a backspace (or a delete) – thereafter if I continue trying to type, every character is a backspace (or a delete) until I enter a space, whereupon I can type normally again. …Until I enter another backspace (or a delete), and the problem starts over.

It doesn’t seem to matter which input method I’m using in SCIM: I’ve tried Greek, Hebrew, Arabic and Russian, and the behaviour occurs in each of them. LibreOffice Writer seems to be unaffected – but Calc is dysfunctional with SCIM.

Any help greatly appreciated!

Additional information (copied from Help → About LibreOffice):
Build ID: Arch Linux build-1
Locale: en-GB (en_GB.UTF-8)

Upgrade to !

Still doesn’t work.

Hi ignotum

First step:

Reset to a default Profile (Q59016) (non-destructive + easily reversible)

They will want to know at the next step that you have tried a Profile reset first. I doubt very much that it will make any difference to your situation, but there is only one way to find out.

Second step:

Repost as a bug (Bugzilla, or by using the Bug Submission Assistant).

Third step:

Add the bug url as a comment to this post (use the format fdo#12345 (see Q16421)).

If this helps then please tick the answer (:heavy_check_mark:)

…and/or show you like it with an uptick ()