Screen rendering when paging up and down Writer documents

Hi. I am new to LibreOffice as I finally snapped at Microsoft Word’s lack of traditional drop-down menus, mainly as I have cerebral palsy and always prefer to use applications via the keyboard rather than my trackerball.

Because I was used to the speed of a Mac, but not the absence of scroll bar arrows, I switched back to a PC, getting a custom built gaming machine to give me the speed of a Mac, have a 4k display, and a fairly new high spec graphics card.

However, I am finding that the slow screen rendering in Writer is often making paging up and down documents to be very disruptive and uncomfortable on my eyes.

I have tried tweeking my graphics settings, but to no avail.

I really do want to stay with LibreOffice, so if anybody can help with a solution, you would make me a very happy lady!

Many thanks,

Cornwall, England

If I use PgUp or PgDn keys, the pages of a 3.5MB document with images and tables render instantly with each press, using my laptop with a simple HD display and integrated graphics.
It might be an issue with the 4K display. Cheers, Al

Some badly formatted files, i.e. manually formatted as is encouraged by Word by lack of adequate primitives, may cause such speed problem but it begins to be noticeable only with huge files.

You didn’t mention basic technical info needed to help you: OS name, LO version, if applicable desktop manager. Best option: paste info from Help>About LibreOffice.

Thanks for the reply!

I have:

Version: (x64) / LibreOffice Community
Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
CPU threads: 16; OS: Windows 10.0 Build 19043; UI render: Skia/Vulkan; VCL: win
Locale: en-GB (en_GB); UI: en-GB
Calc: CL

my PC:

Device name Sarah-WinPC
Processor Intel(R) Core™ i7-7820X CPU @ 3.60GHz 3.60 GHz
Installed RAM 32.0 GB (31.7 GB usable)
Device ID 64C57DCD-8A79-4DD9-9292-9B71778CA8AC
Product ID 00330-80108-32487-AA255
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

Apart from a few tables, there has been nothing other than Arial 12 text, so I am rather baffled as to what could be causing such poor rendering.

Thanks again,

I solved the problem by uninstalling LibreOffice and installing the previous version which has perfect screen rendering in Writer.

However, if anybody could tell me how to disable automatic updates, that would be great as it has just started to download the update.

Many thanks.

LibreOffice on Windows doesn’t automatically update.

Windows patch Tuesday (second Tuesday of the month) updates are being pushed out now. Are you sure it isn’t the Windows updates that are being downloaded automatically? I generally complete the installation and reboot as soon as I can, even in the middle of work. Sometimes the Windows updates causes strange problems until the computer has been restarted