Scrolling too fast on Windows but not on Linux

I bought a new laptop 2 weeks ago (Asus ROG flow x13) and I have tried to understand how to change scroll behaviour for LibreOffice on Windows 10, but I can’t find the real problem.

I booted my laptop today from an external Arch USB install I have, and there the scroll is smooth, consistent with the rest of the system.

On windows I find the scroll to be the same systemwide (explorer, browsers, other apps…) except for libreoffice, where it behaves strangely, too fast to be useful when you just want to go down/up just a bit.

  • On both “systems” I was using LibreOffice v. 7.2.1.2
  • Arch Linux kernel 5.14
  • Windows 10 v. 10.0.1943 Build 19043 (all asus drivers up to date)

So where should I check to know what is happening? Is there any parameter one can adjust to change scroll behaviour within the app?

Bug 119745 - Scrolling with a laptop touchpad in Libreoffice way too fast

1 Like

Thanks! I didn’t knew it was a recognized bug. I added myself to the CC list :+1:. Sadly, after 3+ years of the bug, with even a major release in the middle… sounds like we will have to wait for a very long time :expressionless:.