Setting measurement units in libreoffice base for editing reports

LO (libre office) base reports doesn’t have any setting to set measurement units (like in other modules i.e. writer, calc, draw…). I would like to have units as centimeter instead of inches.

I have searched online and tried to troubleshoot by following steps mentioned below.

  • Reports in base seems to use writer for report building so changed units in writer to cm. didnt work
  • changed units in all other LO module like calc, draw, impress. (no luck)
  • Tried Resetting profile in User\Appdata\Roaming\4\user by renaming it to user.old. (no luck)
  • Uninstalled LO. deleted all windows registry entry using CCleaner.
  • Removed user profile.
  • Reinstalled LO.
  • after installing LO first opened LO writer, calc, draw, impress and set units to cm. and then opened LO base with no luck. still i have inches in report while editing.

Is there any other place where units have to be set. Please let me know. or is there any bug.


Hi Markus, what is your local settings in Menu/Tools/Options/Languages settings/Languages.

For me with Spanish show cm. and with English-US inches.

Hi mariosv, yes i changed language setting to English India from English USA. now i get cm as units.
Thk you.


I found the answer.
In Options → languages settings → languages → change locale setting to English (India) and western also to English (India)
And restart LO.
Now units has changed to centimeter. So there is no bug i guess.