Several Questions on a Mac: Spellcheck, Blurred Display, Spaces

This on a 2017 iMac running 10.14.5

I’m sure all of this is based on some settings that I’ve done wrong, I just can’t figure what they are.

The attached document was produced by someone else. I’m editing it for English usage. So, be aware that it was created by someone who’s settings I don’t know about.

Why does Writer flag “income” as misspelled and suggest “noncomprehending”?

Why are parts of the document out of focus? If I scroll around some parts regain focus while others are blurred:

Sometimes if I select an a word or phrase and then start typing to replace the entire word/phrase the spaces I type will all get stuck at the end of the selection instead of between the words where I type them.

For example:

I type: I saw a dog on the street.

I select “dog” and start typing and I get this:

I saw a bigbrownuglydog on the street.

Instead of this:

I saw a big brown ugly dog on the street.


Why does Writer flag “income” as misspelled and suggest “noncomprehending”?

Show the file. The issue may be about mixing a European language (English) and an Asian (Thai?).

I attached the file. Is there some other way you want me to show it?

I suspect that you’re right about mixing languages, but how do I fix that?

I tried Tools > Language > For All Text > English (USA). But that didn’t seem to help.

My wife frequently prepares documents that have both Thai in English. Is there some settings that she should use to avoid problems?

Also, I should add that we’ve been using LibreOffice to collaborate for several years now. The problems described above have only appeared since updating to We were just fine with

  1. Downloaded the attached file.
  2. Called up the find dialog (Ctrl + F).
  3. Typed in income, hit Enter.
  4. Result: search key not found.

Using LO 5.4.2 (on Windows 7).

My apologies. I’ve uploaded the correct file now.

Fedora Linux, LO 6.1.x: your document displays correctly, so it might be some configuration with MacOS X. A general remark: you seem to use Writer a a mere mechanical typewriter. All your document is styled Default Style, vertical spacing is done with empty paragraphs and stylistic variants are brought in with “direct formatting”. It does not matter for a one-shot single-usage-and-forget document, but it you intend to review and amend the document, you’re preparing for a painful manual work. Learn styles.

You’re very right. These are my wife’s documents. She has no experience with actual word processing. I can’t even get her to format paragraphs using the ruler. She just uses spaces. I would say her chances of learning how to use styles to format stuff are about as good as my chances of learning to speak Thai. Nil in both cases.

Back on topic: So you don’t see the weird blurring or the misplaced spaces when inserting?

Thanks for having a look.

Nope, standard behaviour. But as mentioned I’m under Linux.

No problem with the file here, too. The only two words that are deemed misspelled are proper names, and income is fine. A broken dictionary?

This is weird. On my machine Write flags two instances of “Document” as flagged as misspelled and suggest “Documentation” as a replacement. If I select the entire word “Document” and replace it with “Document” it is no longer flagged as being misspelled. Same with “income”.

I guess we’re going to have to move to a different word processor. We can deal with the weird spellcheck behavior, but the blurriness and strange insertion problem make Writer pretty much unusable. Sometimes parts of the document are so blurry that I can’t read it and have to keep scrolling up and down hoping to get a clearer look.

I can’t help but thing that this is either something we’ve configured wrong in Writer or on the machines, but I’m at a loss to figure out what it is.

Thanks to all for taking the time to look.

I think I have solved at least part of this. Today I downloaded and the blurring problem improved somewhat. At least documents are now readable if somewhat fuzzy.

The spellcheck problem seems to relate to tracking changes. The words flagged as misspelled are all words that got split up by tracking changes:

When I show the changes, Document looks like this:

image description

And income looks like this:

image description

So, it seems the spell checker considers the deleted stuff as well as the stuff that is kept when it checks the spelling of a word. So, instead of seeing “income” it sees “incomwitholdinge” and does its best to come up with an alternative: “noncomprehending”. And, instead of seeing “document” it sees “Dthe document” and suggests “documentation”.

I don’t think this is the way a word processor ought to work. But, what do I know?

I have also solved the blurred text issue by disabling OpenGL.

Preferences > LibreOffice > View > Graphics Output

Uncheck “Use OpenGL for all rendering”

I wonder if your configuration file is corrupted…
see this

I recently had an issue with a corrupted config. I did a test of renaming the directory where it is stored and starting LO. I had an issue where I could not see any cont color other than black in Writer. after the the name change and LO generates new default settings for start up i could see the color of the text.

Seems there are a number of other odd issues reported by users that seem to indicate such a solution.

Well, I figured out what was causing the spell check error. See my solution below. I believe the problem with inserting spaces in the wrong place is caused by the same thing. Writer gets confused by the extra junk in the file caused by enabling Track Changes. If you isolate the discarded (deleted) text from the text you want to keep, then spell checking and insertion work as expected.

The blurriness problem still evades me. One discovery is that if I Select All of the text in the document, the blurriness goes away; at least for a while.

I will experiment with the config files.