Shaking for 5 to 10 seconds when inserting a mere bookmark

Hello. So I had a previous version of Libreoffice and wanted to shift to a new one only because I couldn’t sort out my (very numerous) bookmarks by document order (rather than by alphabetical order).
But now, after having installed the newest ones to change that (I’ve tried the 7.6.5, then 7.6.4, then 7.5.9, each time downloading it and deleting the previous version), I face an even more important problem.
While new versions can read the bookmarks of my document (there are always there), adding new ones has become a chore. When I click on the icon or go to the Insert menu, it freezes and starts shaking for 5 to 10 seconds. So it takes a very long time just to insert a bookmark.

Does anyone have an idea to fix that?
Thanks in advance

os ? hw ?

OK, I’ve solved the problem. I installed an even older version but that’s not how I solved the problem. I removed the Zotero plugin and installed also Libreoffice not via the custom installation but via the classic installation. So it could be one or the other. But I think it’s probably related to the Zotero plugin.