sharing and accessing a database over the lan or ftp network

I’ve created a split database and I’m trying to share it over my lan network and the world wide web with ftp. My lynksys smart wifi has a usb drive that I put the database on. I’m able to reach it using smb:// however when I try to access tables I get:

The connection to the data source “LANdpLAN” could not be established.
The driver class ‘org.hsqldb.jdbcDriver’ could not be loaded.The additional driver class path is ‘smb://’. /build/libreoffice-8BBQp1/libreoffice-7.0.4~rc2/connectivity/source/drivers/jdbc/JConnection.cxx:687
unknown protocol: smb /build/libreoffice-8BBQp1/libreoffice-7.0.4~rc2/connectivity/source/drivers/jdbc/Object.cxx:189

When I download the database to the hard drive I can access the tables no problem. Is there a way to access this database without needing to download it to the hard drive?FYI

FYI here is the database LANdpLAN – Google Drive

unknown protocol: smb

Share on the operating system level using operating system functionality (mount -t cifs ....) and access your network device via mounted share. Doing so makes the storage to appear as a normal path to applications and abstracts the protocol level from the application and delegates it to the operating system.

Opaque: Thank you for the advice. I am looking for instructions how to do this.

I found this video and had success with sudo apt-get install cifs-utils -y and sudo mkdir /mnt/workshare. In the video the folder shows up in ‘Documents’ folder. On my system it only shows up in /mnt
still looking around…

I am shooting in the dark so I tried mount -t cifs and got
mount: can’t find in /etc/fstab.

Next I tried
j@j:~$ sudo mount -t cifs -o username=workshare // /mnt/myFolder/
Password for workshare@// ****
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)