Sicherungskopie kann nicht erstellt werden

Hallo,

ich kann keine Dateien speichern wenn die Sicherungskopie aktiv ist. Die Libre Office Dateien liegen auf nem SMB Share. Lokal ist das kein Problem.
Wenn die Option Sicherungskopie erstellen deaktiviert ist, dann klappt es auch auf dem SMB Share.

grafik

Was kann ich machen damit es funktioniert?

Vielen Dank!

Viele Liebe Grüße

Revan335

Ich kann das Problem bestätigen. Mit den Versionen 7.5 und 7.6 funktioniert das Anlegen den Sicherungskopie, aber mit der Version 24.2.0.3 schlägt es fehl :frowning:

1 Like

Kann ich nicht bestägigen mit einer URL smb://User@192.168.15.2/Daten/Pfad/Dokument.odt und mit:
Version: 24.2.0.3 (X86_64) / LibreOffice Community
Build ID: da48488a73ddd66ea24cf16bbc4f7b9c08e9bea1
CPU threads: 4; OS: Linux 5.15; UI render: default; VCL: x11
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded

Das ist wenig hilfreich.

Das Probleme besteht definitiv.

Dokument öffnen, Speichern → Fehler
Dokument öffnen, Speichern unter → Neuen Namen festlegen am gleichen Ort → Funtkioniert
Noch offenes Dokument mit dem neuen Dateinamen → Erneut auf Speichern → Fehler

  • Share ist per automount im Filesystem eingebunden (=keine smb://… URL als Pfadangabe)
  • Speichern unter 7.5 und 7.6 mit eingeschalteter Sicherungskopie funktioniert einwandfrei, nur halt nicht mit 24.2.0.3

Hallo, bei mir dasselbe Verhalten seit der Version 24.2.0.3: Speichern auf einem smb-Laufwerk geht nicht, Speichern unter … mit neuem Namen geht. Dann wieder Speichern mit dem selben Namen, kommt die Fehlermeldung. Wenn ich auf dem Linux-Laufwerk (ext4) und auf einem nfs-Laufwerk funktioniert das Speichern ganz normal.

Aus irgend einem Grund scheitert das Anlegen der Sicherungskopie im Ordner ~/.config/libreoffice/4/user/backup
Es wird zwar eine Datei angelegt, mit dateiname.ods.bak bzw. .odt.bak, diese hat aber eine Größe von 0

Das Problem gab es wohl früher schon mal, vgl.

Aber da gab es leider keinen Lösungsvorfschlag.

Bei mir hatte es allersings auf demselben System mit der vorherigen Version 7.6.x noch funktioniert.

Mein System: Manjaro Linux

Selbes Problem, gleiche Fehlermeldung bei mir. Daten liegen auf NAS.
NAS Anbindung mit CIFS, Host ist MX Linux 23.2. Lokales Speicher mit LO Clac geht, aber nicht wenn Datei auf NAS geändert wird und wieder gespeichert werden soll. Erst seit Update LO 24.x, heute Update LO 24.2.1.2 gemacht, gleicher Fehler. Zuvor mit letzter Version LO 7.x hat alles funktioniert. Gehe jetzt wieder zurück auf 7.x.

BTW: MX Linux 23.1 hatte im Nov/Dez '23 Kernelprobleme, davon war NAS via CIFS betroffen.
Standard-Kernel 6.1.0-16 bis aktuell 6.1.0-18 hatte ich das Problem, das eine leere Datei zwar einmal auf NAS erstellt werden konnte, dann aber keine Kopie mehr davon. Fehler scheint bekannt zu sein, doch scheinen es nur wenige bisher bemerkt/gemeldet zu haben. Das Problem ist immer noch präsent im neuesten Kernel, workaround bei mir: Liquorix Kernel 6.3.x bis 6.7.x gehen alle ohne Probleme mit NAS Zugriff (via SMB 3).

2024-03-02 LibreOffice Calc, Datei auf NAS nicht speicherbar

Mit NFS funktioniert es. Weiß aber nicht mehr ob es da auch schon die 24.x war als ich es getestet hatte. Ist schon was her.

fstab cifs und automount wie beschrieben funktioniert nicht. Per smb URL hab ich es glaub noch nicht getestet.

Wie soll den irgendjemand wissen, was bei Dir nicht geht, wenn Du es nicht detailliert hier hinschreibst?

Falls du mich meinst, geht es hauptsächlich um SMB. Das geht nicht, wenn die Sicherungskopien aktiv sind. Wie genannt.

NFS hatte ich dann mal getestet da ging es wie gesagt.
Mit aktiver Option.
Lokal wie gesagt, auch.

@sumpffuss Sieht bei mir auch so aus mit dem Datei Verhalten. Beim neu erstellen wird noch keine Sicherungskopie benötigt, deshalb geht es. Wenn schon vorhanden, dann ist diese notwendig.

Ich kann aber nicht sagen welche Version es wann war. Da ich durch EndeavourOS/Arch Basis die neuste bekomme. Hab es zuletzt also mit einer 24er Version versucht.

Über CIFS funktioniert es auch nicht. Habe die gleiche Fehlermeldung. Das Problem tritt bei mir auch erst seit der Version 24.2.0.3 auf. Ich benutze Linux Mint 21.3

Speichern unter funktioniert dann aber :sunglasses: