"[" Sign Appears when Commenting on List Item


I am using LibreOffice on Linux Mint 17.1 32-bit.

Recently, in Writer, I ran into something strange, which I believe to be a bug, but I would like to be certain of all the details before I report it.

While working on some homework, I noticed that comments that mark the beginning of a bullet/numbered list item get a little left square bracket sign ("[") in front of them. If you try to add a comment to the middle of rhe item, or to a text that is not a list, the bracket does not appear.

It’s also worth mentioning that when record changes is active, deleting the comment and then the bracket sign and trying to save causes a crash.

The question is, why does the bracket sign appear in the first place? Is this some sort of feature? If it’s not, then it’s a bug, but if it is, then the crashing is bug.

Here is an image showing the different comments and their effect. I fear the explanation might not be enough.

Thanks in advance!


Adding the picture was very helpful.

I used 4.2 very intensively with numbering and comments and did not observe the “[”. I use an XP machine.
In I could not create the “[”

In case of strange behavior of LibO, a reset of the user profile helps very often. I would reset my user profile. For details please refer to: https://wiki.documentfoundation.org/UserProfile

If then it does not disappear, I feel you found a bug.

I am sorry to hear that reset did not work. It would have been so easy.

Can you upgrade or downgrade LibO? I know in Linux it is not that easy. On an kubuntu machine I will try to upgrade for the first time using most likely LibreOffice Packaging in Launchpad . The maintainer is Bjoern Michaelsen, well known in LibO. This I can trust this ppa-site.

Thank you for the quick answer.

I tried to change the user folder’s name. A new user was created, but the bracket still appears. I will now go and file a bug report.

see EDIT in my answer

Running LO, the problem appears to have been fixed. I already filed a bug report, but perhaps I was too hasty. Good to see that it’s taken care of, though.