sign in methods

When I tried to change my login method, I was offered an assortment of account-types to which I could connect: Twitter, Facebook, !Yahoo, Google, etc. I don’t have an account with ANY of them. I use the Brave Browser, I don’t have or want social media accounts. Why can’t I just go to the web-site, provide a User ID and password, and sign on? That is how I USED to sign on here. Is that no longer an option?

This has happened to me several times when I hit Return instead of typing my password. I just pressed the Back button to return to the sign in page and to try again. Worked fine.

I assume your question is about this site, though you tagged common meaning you have a general problem with LO. So, please, retag to replace common with meta. Press Enter twice to exit retag mode.

What is “Brave Browser”?

Here’s the page. It indeed contains fields for password. Although it could be possibly different if your current login method is different from mine … then it might be a bug, something to inform admins at redmine.