Since 6.3 Solver hangs up Calc

I am using in one of my sheets a complex solver formular. It worked fine in older LibreOffice versions, however, with all 6.3* versions on all platforms tested (Windows x64 10, Linux) it starts to run and then hangs. It also affects all other open sheets, even when not used.
What I did:

  • Create a complex solver formular as LibreOffice Basic
  • Configure a button in the sheet which starts the program

When the sheet is just open printin of another document shows the “printing” dialog (page 140 or 140 even if it is only 1 page), at it stays there. Nothing happens, no printing.
When the button is pressed (alternatively the macro is started from the menu), the solver comes up and starts and then hangs after a few ms. And sticks.
1 CPU core is at 100% and it stays there.

As mentioned, versions before 6.3 worked without any isse.

Any idea what the problem is and how to solve it?

Another side isse, that might be related: The button flickers under 6.3. In former versions it is just displayed.

Could be bug #tdf128077

Following I just noticed (updated my Suse Tumbleweed):
Under Linux: the solver does not work at all. However, with LXDE the flickering of the button is not there

Under Windows: When I turn off OpenCL the solver works with the latest version of 6.3 ( x64) and the flickering of the button stops.

So, bottom line, OpenCL might be an issue. I run Windows 10 x64 Pro with an Nvidia Quadro M4000.

Under Linux: the solver does not work at all

Note that solver might need Java