Slideshow error in Impress: Slides whited out in top left corner

Would very much appreciate some help.

I’m due to give a presentation and was relying on Libreoffice impress. I’ve completed editing all my slides but when I come to play the slideshow, several slides are obscured by a white triangular area on the top left. It seems like the identical issue noted here:

But the solution suggested of disabling hardware acceleration has not worked in my case.

Please can someone assist with another suggested solution?

I’m running Windows 10 (vs 21H2) on an MSI Laptop with an Nividia GTX1050 graphics card. My version on Libreoffice is (x64)

Thank you so much in advance.

Can you share a small sample presentation that shows the problem?

In the linked question, I can view the presentation OK. If I enable Skia then I cannot advance through the slides but see only the first slide until I have clicked enough times to end the slideshow (or escape out of it).

Is there an update available for your graphic card drivers?

Are you using Skia?

EDIT: If so, try disabling it.

1 Like

Thanks so much for your response EarnestAI.

My graphics card drivers are up to date.

The photo I uploaded with the original post is exactly how the problem appears. It is, however, not consistent, and hard to replicate. Some slides display perfectly on the slideshow. Around half a dozen as shown.

If I can find a way to replicate the issue I will try and upload a sample slideshow, but until then, do any suggested solutions come to mind?

When I play the sample slideshow from the post I linked to, the Japanese slides appear fine on my system and I don’t can’t the same error as in my own photo. I linked to that post simply because the description of the issue sounded very similar.

Perhaps there are some Nvidia settings I need to tweak?

A bit out of my depth with it, so any support is very much appreciated.

Thanks again!


Hi. First a bit of etiquette, don’t use Answer / Solution if you want to make a comment; click the comment icon.

Counter-intuitively, setting Tools > Options > View > Force Skia software rendering might work, see comment 15 in bug tdf#144923 . I tried it on the laptop that wouldn’t advance the slides when Skia was enabled and forcing Skia allowed it to work correctly too. I guess the setting makes Skia override some other rendering (OpenGL?). It says Skia/Raster in Help > About Libreoffice now.

Do the slides with the triangle have a different transition than the ones that don’t?

[Edit] Probably best to post as bug, especially if Force Skia doesn’t work, see How to Report Bugs in LibreOffice - The Document Foundation Wiki

Thanks Earnest AI and BigRAI. And apologies - didn’t see the “comment” icon originally.

I’ve tried with Skia disabled completely, with Skia enabled, and with Skia forced. In all 3 instances the issue remains.

I haven’t changed anything about the transition on those slides where the white corner is present, and they seem to behave identically in all other ways to the slides that are entirely visible.

I’ll report the bug. Thank you. Please do let me know if you have any suggestions at all in the meantime.

OK, I have now found a solution.

Feel pretty embarrassed to admit that I thought I was running the most up to date version of Libreoffice but I wasn’t.

I upgraded from to and for some reason that upgrade has ironed out the glitch. Slideshow seems to be running perfectly now, thankfully.

EarnestAI and BigRAI - thank you both again for your help in any case :+1: