Slow Context Options for Spelling Errors

My context menu has become slow for resolving identified spelling errors. Is there a way to improve this (other than not making spelling mistakes). I’m running Fresh versions and this has been happening for 5.2 and now 5.3. Running Win10 on 2yr old PC

Same problem here. LibreOffice basically freezes up while waiting for the context menu to load. It only happens when right-clicking misspelled words: no context menu issues any other time. It’s as if the program is spending long cycles searching the dictionary, while I’m forced to wait.

A total removal of LO and then re-installation worked for me… for awhile. This week it started happening again. I can’t figure it out, but it’s supremely annoying. Also Win10, running LO

Exact same problem. Re-installs don’t seem to help (did some yesterday for another reason, and in fact it’s even worse than I remember from before those re-installs). It’s a pain, because I use that option a lot to add items to the autocorrect list.
I hope someone is trying to fix this.

I have the same symptoms
Win 10, L.O.5.3
I regularly use 2 or 3 natural languages in the same document
and I have quite a few dictionaries installed as AddOns.
This slows me down quite a bit.

Is there a LO version that doesn’t have this problem. It’s getting so bad I think I’d prefer to revert to an older version rather than be stuck with this.

Try restarting LibO on safe mode (Help → Restart on Safe Mode): if that fix the problem you need to reset your user profile (also using the Restart on Safe Mode dialogue).

Help —> Restart on Safe mode? There is no option “restart on safe mode” under help.

And in Help (apparently only online now) there’s nowhere any clear instructions as to how to start the programme in safe mode either.

The option was introduced on 5.3. To reset your user profile on earlier versions, see LibreOffice user profile.