slow repository version vs appimage when gpu is maxed


When running boinc (Berkeley Open Infrastructure for Network Computing) doing some distributed scientific research and when it maxes out the gpu, the deb version (from repository ) is extremely slow bordering on unresponsive.

This doesn’t happen when running the appimage. But , of course, the appimage takes longer to start.

Already tried on/off opencl, java. Went also through “all” settings comparing repository version / appimage and restarted libreoffice in safe mode.

any clue?

please more Information: your OS ? and also the Info from -> Help -> about Libreoffice

oops, sorry.
o.s.: kde neon (linux)
ram: 64GB
gpu: gtx 980

help->about with the current installed:
Id. de compilación: 1:6.4.7-0ubuntu0.20.04.1
Subprocs. CPU: 12; SO: Linux 5.4; Repres. IU: predet.; VCL: gtk3;
Configuración regional: es-ES (es_ES.UTF-8); Idioma de IU: es-ES
Calc: threaded

help-about of appimage (not the latest):
Build ID: 64390860c6cd0aca4beafafcfd84613dd9dfb63a
CPU threads: 12; OS: Linux 5.4; UI render: default; VCL: kf5
Locale: es-ES (es_ES.UTF-8); Interfaz: es-ES
Calc: CL

This seems to happen regardless of the repository version (all the way back to ver 5.x) or appimage.
Tried it a while back with same libreoffice version of appimage than repository/deb, same problem.
There must be something different enought from appimage/repository that works better when gpu is saturated. I see vcl is gtk3 versus kf5 and calc: threaded vs CL