soffice --headless doesn't execute in subprocess using Pycharm & LibreOffice 6.3 - gives error


Here is my situation: I had a perfectly working Ubuntu18.04 LTS-system installed in a virtualbox. I have a little program in python which converts files with extension .doc to .docx and then saves them in another directory. The conversion takes place in a in python. This also worked perfectly.

But, for this Ubuntu-system I had only 15GB of HD-space so I wanted to expand this, which worked, at least that’s what it looked like, but it seems that my Ubuntu-system didn’t want to boot anymore. So I was left no choice to take steps to create a new virtualbox file, with new Ubuntu18.04 installed, new libreoffice, new pycharm, etc…

The problem: I tried exactly thesame little python-program like i used before, in the other Ubuntu-system but thisone doesn’t want to do the work. I have been trying many things like removing libreoffice, reinstalling, updating, using many different web-sources to try again and again and again but I can’t come to a solution. I have no clue what I actually need to to do make this program work again.

The error which I’m getting when the[‘soffice’, ‘–headless’, ‘–convert-to’,‘docx’… is executed is thisone:

Error: source file could not be loaded

Process finishted with exit code 0

I already googled with terms like “Error: source file could not be loaded libreoffice” but with all the possible webpages I found, I didn’t find a solution for this problem.

Does anyone have any idea about how I can get my code to work again? I’m sure there is no problem within my code itself…

Have you tried to call soffice using full path to soffice?

Hi @Dejrgn did you find the solution?