[SOLVED] accentuated characters in LO


As seen in quite a few posts a lot of us have problem with accentuated characters: e.g. "+u → ü, '+a => á, etc.
Usually an upgrade of either OS or LO version may explain that a user profile may somehow get partially corrupted. The problem is that the issue leads to an apparently erratic behavior inside modules. Sometimes accents thru key combinations can be used for a few seconds after module launch and then not anymore. Sometimes what triggers the problem is when the mouse hovers over a menu or when the CTL key is used the first time inside a recently opened module document, sometimes a key combination say ^+ e produces a ^e, instead of ê.

It all depends on … what ? Nobody seems to know and users ought to be surprised that nobody is in a position to say: “All right folks, this is a known bug, with bug number xyz”. Or “you have a faulty library”, or “Reinstall completely because such and such dependency is compromised beyond repair”. Are there devs working on this ? Is it considered important by the dev program leaders or even by the forum moderators or managers ?
Is it in the queue of things to fix ? Can we know ?

One aspect of the problem is that rebuilding the user profile from scratch ( a common advice offered by would-be helpers ) does not always help to solve that accentuated character problem.

For me everything worked well under LO 4.2. Today (under 4.4.3) I have zero accent previously available through key combination, irrespectively of the LO module. This occurs LO wide. There was no behavior change at all with a brand new profile-rebuild and after wiping out my few extensions and dictionaries in the process (no big deal, I had a total of 4).

The said key combinations continue to work in any other application outside LO. So it MAY be related to the system but it MUST also be related to LO !

Is someone knowledgeable enough to venture an educated suggestion as to whether people affected are missing a key library or something akin to that, or something else ?
Seriously, folks, what’s to do here ?


Upgraded to LO
Suppressed the problem completely.

Amazing how little interest there is on this forum for such problems.
By the look of the posts on the same subject, it is a little surprising.

This forum is not a developers forum but one of “would-be-helpers” who not too rarely prove to be actual helpers, too. The contributors here are simply users of an experiene hopefully a bit above average.

That your topic does not find running in many contributors might indicate that it hasn’t the big impact you suppose. As far as technical knowledge is required to comment on your question, it may simly be not available to the helpers here. You surely searched the bug reports and feature requests thoroughly?

This is off-topic but I’ll keep it real short.
If this did not receive any attention it is (in my grew-from-noob-experience) probably NOT because so very few are affected, but probably because non-techies tend to just move on because there is no way they are going to invest the amount of time needed for them to pursue any issue technical. That amount of time would be huge for them.
Naturally I looked up “Bug reports and …” Nothing of significance applied.

@Cbhihe I invest a lot of time for my contributions here, and sometimes also to file or to improve bug reports. I couldn’t do it if I wasn’t retired. In this case I wouldn’t invest time because I have no hope to get beyond “new user profile” or “complete uninstall and subsequent reinstall”. Using LibreOffice and its predecessors for decades now I never experienced this problem. It might, of course, also be related to the OS/keyboard driver, even if other applications don’t show the same issues.

@Lupp: your contribution IS greatly appreciated I am sure. Honestly ! Plus I have no quarrel with you or with anyone here. LO is mostly a beauty as far as what its code acheived is concerned. My point is different. I do not lack appreciation for your involvement or that of others in your case. [DE] Bitte, les mal was ich auf den Post Perternaus geantwortet habe.

I can understand the frustration on the use of accented characters, different languages and the use of the 110,000 Unicode characters available for use on computers and LibO. Not forgetting the � often found when (’) was intended. Also the little box instead of a character when that code does not have an entry in the font in use. I have a paper copy of the Unicode containing 1500 pages next to paper copies of all the LibO manuals, as well as computer keyboards in five languages (English, American, French, and Swiss (French, German) running on Linux Ubuntu or Mint which I use for my retirement work and helping out on questions where I feel I can help.

A problem with accented characters is that there are a number of variables involved, the keyboard definition, language sticky keys, the system language itself, fonts installed. Within LibO you also have the User Interface, Locale, currency, date format, dictionary language etc. So it can be quite difficult to give useful short remote advice from the limited information provided. In many cases the problem may show up with LibO and is in fact a general system problem.

Many volunteers do help to test LibO and help give answers if they can, as do many helpers on other software systems. For example accented character problems using Ubuntu. So a simple answer, does anybody care or know about accented characters. Yes. But don’t automatically assume it is LibO. I always advise new users to download the LibO Getting Started manual,as it has lots of useful information including answers to questions you might ask in the future.

Not meant as a rant, but I hope we can clear up some of your problems bit by bit…Peter

@peternau, thanks ! 1) yr post doesn’t come across as a rant. It gives valuable general perspective 2) I wasn’t intent upon disparaging any1. I expressed genuine surprise at the fact that unlike in, say, StackExchange or Unix & Linux fora, there doesn’t seem to be much technical depth where it is needed here. I usually try to understand faults in either install, config or LO myself. It is frustrating that short of dealing directly with code, the only answer seems to be reboot/reinstall/upgrade…