[SOLVED] 'arrows' and 'delete' keys disabled in LO-Writer


Bizarre issue here:

I imported customized keyboard shortcuts from a different machine running same LO version (5.3). The two machine run Ubuntu.

The import was performed by going to Tools> Customize> Load and selecting the ‘Writer’ radio-button.

As a result my arrow keys and delete key on my brand new keyboard are disabled in Writer.

LO packages other than Writer show no issue.

This happens for ALL writer documents, old and new, before and after reboot.

How do I recover from that ? … I mean, short of purging and reinstalling the whole shenanigans ? Can I selectively reset Writer, its profile or a file functionally equivalent to a profile ?
Any help appreciated.


In addition I just purged my system from Libreoffice modules

     sudo apt-get remove --purge libreoffice*

and presumably config files and reinstalled it. That was a total of about 337 MB of storage space.

I relaunched LO after reinstall and checked the Recent document option on the left pane of the LO window, EXPECTING not to see anything inside. All my previously opened docs were still there. How is that possible ?
So the purge did not work.

How can I fix that and have a functional keyboard in Writer again ?

A quick test suggests that the changed keyboard settings are stored in your user profile which is probably not removed from your system via apt-get as you have used it.

Try resetting your user profile - see the link above - and when your restart LO you should be asked for your name and initials.

If this answer helped you, please accept it by clicking the check mark :heavy_check_mark: to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.


The description of the “profile” and its cleaning are described in more detail in this FAQ.

Since version 5.3 has also been introduced a safe mode. See the release notes.