[Solved] Data validation->List, LO always crashes

I wanted to add simple Yes/No list on my column in a spreadsheet. I marked the column, unmarked the first cell (which has a description) and Data->Validation->Citeria then I choose List but the moment I do this, LO crashes ALWAYS. So I’m unable to create a document I want. I could create it easily in Google Sheets but they are sluggish and I just need local file.

Operating System: Manjaro Linux
KDE Plasma Version: 5.15.4
KDE Frameworks Version: 5.57.0
Qt Version: 5.12.3
Kernel Version: 5.0.10-2-MANJARO
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-6700HQ CPU @ 2.60GHz
Memory: 7,7 GiB
Libre Office: 6.2.3-2

I tried to open LO in terminal to see some application output but nothing, LO is completely mute, no output (opens correctly thou).

I found a workaround by installing LO snap version and this didn’t crash but had many other glitches, nevertheless, it allowed me to add the list and save the document. Opening in native LO list works correctly. Only adding something is a problem.

How to debug it? Or simply maybe I should just report this bug?


Given that (1) it works for you using snap; and (2) it works here on Windows with, you are advised to file a bug against your distro packaging team (because it’s likely that problem is there).

I guess I must find out is the bug generally affecting everyone on Arch-base or is it just me.

Still, some debug info would be nice. I was surprised to see no output in the terminal. Usually, application spawns there everything that is happening, which is very helpful for debugging. I guess this output is hidden on purpose but I can’t understand it since LO is open source and should be… well… open ;).

We suppress debug in release build, since we have wast amounts of (largely useless) debug output, and no useful separation between developer- and user-related debug info; and that output affects performance.

Thanks for the info. How do I find some debug info on crashes then?
Is it even possible on Arch-base since it has no debug symbols for packages yet?

you might use debug builds from TDF - but then, it’s unlikely that the problem specific to your distro packaging would be there.

Also, possibly your distro package doesn’t have the output compiled out; try enabling it using SAL_LOG=TRUE soffice

See also https://wiki.documentfoundation.org/Development/How_to_debug

Thanks for the info!
I found out that crash is caused by using Kvantum theme and when I force Breeze theme (default to Plasma desktop) all works fine and there is no crash :).

Oh! Then it is worth filing to our bug tracker (if it’s reproducible), with a link to the theme. No matter if a theme is broken, we shouldn’t crash.



Thank you!