Solved: diagram is not updated when new data have been included

I have a x-y-diagram. The x- and y values are defined as follows:
x: $Liste.$A$2:$A$1812 - these are date values like 17.06.2022
y: $Liste.$A$2:$A$1812 - these are normal numbers like 635,70

add new data lines by copying them out of a csv file
update source data strings accordingly

expected result:
new data show up in diagram

actual result:
new data don not show up in diagram

I tried the following to no avail:

  • check whether there is no invisible ’ in the data, thus forcing them to be a string
  • F9
  • shift + F9

Cause found at last:
the data in the x-column had been interpreted as text instead of calendar-date during the opening process of the csv-file.

Solution 1:
switch on “advanced number recognition” in the open-file-details-window when opening the csv file. this does not change the column type shown in the said details-window, but in the open file, the data are marked as calendar-date.

Solution 2:
mark column as “calendar date” by hand in open-file-details-window when opening the csv-file. same effect as 1.

Solution 3:
In the ods file with the diagram,

  1. mark the x-data column, set manually: - format - number format - date
    this will give them the calendar-date property, but a " ’ " is added by calc into the newly inserted data cells, because calc wants for some reason to retain the “string” property of these cells. so we have to proceed to step 2:
  2. menu bar - data - text in column - (make sure all separation charakters are unselected) - ok
    this will remove the " ’ " in the new data and thus they have unmodified “calendar date” property.

new data are now shown in the diagram.