{solved} Help re: mailing labels - data is not merging into formatted fields at all

Hello, I’ve never done a mail merge before (or don’t remember doing so or how if I did, though this seems sort of familiar) & am in a bind as volunteers have shown up to help send out a mailing, but was just sent the .xls spreadsheet.

Portable Calc version7.6.4.1

Following the instructions on this page:


# Printing mailing labels

But when I print to .pdf the data doesn’t merge in to the appropriate (or any) fields:
(see the print screen below)

Screenshot 2024-02-09
Screenshot 2024-02-091916×1017 134 KB

Any help would be greatly appreciated. I’m in a little non-profit trying to send out a newsletter & volunteers showed up but the guy who sent a .pdf for the mailing labels has them in some random order & they can’t be matched with the correct mailing list without tons of work.

I am tasked with trying to resort the list (done) and putting them in a .pdf to email them so that they can print the labels so everyone can live happily ever after. Things are not looking good at this point.

Thank you very much for anyone who can provide any help!

Sorry, I was trying to save people from having to read all of the original info about my struggles, but I can see that it might be pertinent for some people. I added it back & put the solution at the bottom.

fwiw, I was also struggling with trying to revert it back & edit it. For some reason it was using html type formatting when I reverted to the older version. I couldn’t quite figure it out, but fortunately it mostly corrected when I saved the edit.


I was using the file > print option, which obviously just printed the rough formatting without merging in the data. I accidentally found the correct icon, which was: “Print Merged Documents”. See the screenshot with the very shaky red arrow:

BUT, for some reason printing to Microsoft PDF was inserting a blank page after every good page. For me, it worked better to click the “Save merged document” icon (see image below)

save merged documents

Then I opened the document and exported directly as a PDF rather than “print to PDF”

File > Export As > Export Directly as PDF

That eliminated all of the blank pages for me.

1 Like