Solved -LibreOffice 4.1.5 - Error - not open network files

LibreOffice (linux -Ubuntu 12.04) -Error -not open network files (samba) using nautilus. I installed this version by downloading the files from the libreoffice website and installed using sudo dpkg-i *.deb (As I always do)

Too when I install LibreOffice using ppa, I get error when opening network files .ods .odt

This error is very serious for a recommended version for all users.

LibreOffice 4.2.1 is targeted for early adopters and private power users.

I do not want more surprises …I return to my old familiar LibreOffice 4.0.6

Solved (LibreOffice 4.1.5 - Ubuntu 12.04 ):

After installing LibreOffice 4.1.5, put in the terminal:

sudo sed -i ‘s/X-GIO-NoFuse=true/#X-GIO-NoFuse=true/’ /usr/share/applications/libreoffice*

Report a bug against 4.1.x using bug tracker. Also try installing 4.2 and if problem still appears report a bug. Bugs do not get fixed if there are not reported. Also 4.0 is fine if it is working for you, but it is at the end of life status: and 4.1 is also approaching end of life in end of April.

Also if you would really like to solve the problem it would HELP A LOT if you could install 4.1.1 and see if the problem appears, if not install 4.1.2, then 4.1.3, then 4.1.4 and finally 4.1.5 - until a problem appears. To get the first problematic version it dramatically reduces the time for developers to track down which of the update created your problem.

It seems that this error is only for Ubuntu 12.04, using LibreOffice 4.1.x or 4.2.x. Several people reported this error.
I guess it’s caused by old versions of GNOME\Samba libs.
I found no solution.

Download LibreOffice Ubuntu / Debian :

I know there were some problems opening network files. The work around is to copy network file to local disk, work with the file in LibreOffice and then save back to network drive.

Edit: You may try to install latest stable 4.2.x on one of the PCs to see if this problem is already fixed. For Ubuntu follow the following tutorial: LibreOffice-4-2 PPA for Ubuntu 12.04 / 13.10 - How to install - Tutorial

Thank you very much for your answers!

Moving back to 4.0 if you really need stable environment is wise to do. But on the other hand I still suggest to install LibreOffice 4.2 on one of the test PC and test if this problem is fixed. If not then I suggest to report a bug to bug tracker. You may be having a unique problem and if so it will not going to be fixed without a bug report:

Also, refer this answer for GVFS-related issue and workaround.

Thank you very much!
After installing LibreOffice 4.1.5, put in the terminal:

sudo sed -i ‘s/X-GIO-NoFuse=true/#X-GIO-NoFuse=true/’ /usr/share/applications/libreoffice*

Thanks Gogon69

I did like you said (the sed command)

I modified all files in /usr/share/applications/libreoffice*

Commented out the “X-GIO-NoFuse” property and it fixed my problem. Now, I can open network files :smiley:

I’m surprised that the bug hasn’t been fixed yet (LibreOffice 4.3.4)

Any idea what that “NoFuse” does??