[Solved]Libreoffice Writer cannot access documents on Synology NFS share

Dear all,
some days ago, I installed LibreOffice on Ubuntu 20.04 LTS on a Lenovo Ideapad 5.15. So far, everything seems to be running nicely with one rather large exception.

Together with my Laptop I am using a Synology DS215j running on DSM 6.2.4-25556. On that NAS, there are a couple of shared folders, mounted via fstab entries following the schema:
SomeIPv4address:/volume1/fum /mnt/fum nfs auto,user,defaults,rsize=32768,wsize=32768,tcp,intr 0 0
using nfs 3 and AUTH_SYS authentication.

Again, everything seems to be running nicely. However, when I am trying to access files on the shares with LibreOfficeWriter LibreOffice freezes. By accessing I mean trying to open documents in Nautilus, trying to do so via the ‘open’ menu entry or trying to save newly created files to the share. After a quick check, Calc seems to be having the same issue.

Is there somebody out there, who could help my with that problem? I found several related requests throughout the Internet. All of these seem to be concerned with the SMB protocol, though.

So, thanks a lot in advance! I am looking forward to your answers!

Best Regards,

I have the rights to write in that folder. The document I was trying to open was one I copied into the share


ls -ln / | grep mnt:
drwxr-xr-x   7 0 0       4096 Apr 10 14:34 mnt

ls -ln /mnt | grep fum:
drwxrwxrwx  7    0   0  4096 Apr 10 23:37 fum

uid=1027(username) gid=100(users) Gruppen=100(users),4(adm),24(cdrom),27(sudo),30(dip),46(plugdev),120(lpadmin),131(lxd),132(sambashare),1000(username)

I also tried re-installing LibreOffice following Opaque’s instructions, albeit with German helpfiles. The problem still remains

[Edit - Opaque] Changed commands / output to pre-formtted text


Using the fstab entry

SomeIPv4address:/volume1/fum /mnt/fum nfs defaults

did not change the behaviour, neither by using sudo mount -a (after unmounting of course) nor by rebooting. I have not used the vers parameter.

Opening documents in read-only mode seems to be working. Removing the write protection again leads to Writer freezing.

It is the Synology firewall. I do not know which rule yet, but when I switch it off completely, LibreOffice seems to work nicely

Use fixed port for nlockmgr and enable that port in firewall settings

First question would be: Do you have the rights to write in that folder?
Try to copy an existing file in the directory first.

I do have the rights. The document I was trying to open was one I copied into the share

The document I was trying to open was one I copied into the share

… however, when opening such file, you need to have permission to create a lock file, which is a hidden file and named .~lock<filename_of_what_was_one_I_copied_into_the_share>#. There are cases where creating hidden files is forbidden.

> mounted via fstab

This generally means, that the mount is being performed as root and unless you show us ls -ln / | grep mnt, ls -ln /mnt | grep fum and id output (while logged into your user account and not being root), I got some doubts about correct permissions.

> I installed LibreOffice on Ubuntu 20.04 LTS

If this is really a new installation, you may want to give (full Un-/and Re-installation):

  • dpkg --list | awk '/ii/&&/libreoffice/{print $2}' | sudo xargs apt purge --yes
  • sudo apt autoremove --yes
  • sudo apt update --yes
  • sudo apt install libreoffice libreoffice-gtk3 libreoffice-sdbc-hsqldb libreoffice-help-en-us

a try.


Please do **not** use *Add Answer* but **[edit](https://ask.libreoffice.org/t/solved-libreoffice-writer-cannot-access-documents-on-synology-nfs-share/63478)** your original question to enhance the details of your question and/or to upload sample file(s) (answers are reserved for solutions to a problem on this Q&A site). Thanks in advance …

Just installed a LibreOffice on an Ubuntu 20.04 system and cold reproduce your issue when using your mount options (i.e (auto,user,defaults,rsize=32768,wsize=32768,tcp,intr,vers=3).

Using only option defaults works for me (on my test vers=3 causes the issue).