(Solved) Linux LibreOffice Impress flickers when displaying slides

I am using Linux Mint 19. When displaying slides the screen flickers 3 times. I tried LibreOffice for Windows. No problems. Slides displayed with no screen flickers. Why is this happening with Linux?

LibreOffice Impress is a little buggy. I will continue to use Office365 PowerPoint.

Problem Solved! The reason the screen flickers when displaying slides has to do with slide transitions. I removed all slide the transitions. I tested this under Linux and Windows. Problem solved!

Now I can transition over to Linux from Windows.

  1. Write your answers in an answer, not in the question; 2) What you indicate as a “solution” clearly isn’t: it is a work around: you are just not using the feature that causes the problem anymore.

Thanks for the reply. There appears to be no help at the links you mentioned. In searching Google for a solution it appears this problem with Impress continues to be a problem for quite sometimes. No one has offered a solution. I need a program that is reliable and stable since I will doing 8 presentations. PowerPoint meets my needs at the moment. I hope the Open Source programmers read this forum and see the exists with Impress.

It could be this bug.

You can also search for yourself in Bugzilla:


I use Linux Mint too with Nvidia Gt1030 graphic card. Which version of LO do you use ?. Could you tell us some details about your graphics card, is it dual screen ? driver used (nvidia / nouveau / intel HD graphics / etc ) ? VGA/HDMI output ? I noticed nothing about this. Do you use transition animation between slides ? If yes, try to desactivate them.

Yes, the solution is to remove slide transitions. I use Linux Mint 19.1 with nvidia.

Hi, had the same issue.

Apparently there is a workaround to minimise flickering.

Go in Tools > Options > Libreoffice Impress > General and uncheck Use background cache

It worked for me.

I tried this and it did not work. The solution to my problem is to remove slide transitions.

Make sure there’s nothing overlapping your videos (e.g. text boxes) and that your videos aren’t placed on the edge of the slide. That helped for me

Thanks for the suggestion. I am back using LibreOffice from Office 365. I will see if this resolves my problem.