solved:printer setting changes to genric printer

OS=ubuntu 12.04 64bit


I am running ubuntu on client through LTSP. Since on server i have added 2 network printer through CUPS and shared between my Fat Clients. I am able to print successfully, but sometime in middle the default printer changes from:

…to Generic Printer:

Printer Setup

i tried this /usr/lib/libreoffice/program/spadmin and set default printer but again in middle it goes to generic printer

How do i make any one printer default system wide?





@vnc786 @oweng Has this been solved? If so, write an answer explaining what you had to do, then mark it as the correct answer (the tick / check underneath the vote boxes) so that this can be cleared from our to-do list.

Sorry, I was working on formatting the answer :slight_smile:

My goodness, the update link in the original question appears to point to several issues and solutions, any one of which may have been the cause of this problem. The central issues appears to be CUPS timing out and resetting the printer to a “Generic” option. The final solution appears to have been a CUPS update. Here is my TLDR summary for others:

  • Bug fdo#50784 points out LO/CUPS time-out issue.
  • Bug LP#1020048 is raised to track the issue for Ubuntu.
  • Workaround / solution is suggested in fdo#50784 and taken up by OP. “I fixed it setting “TimeOut 7200” in the /etc/cups/cupsd.conf on the print server.”
  • Resolution of fdo#50784 is disputed (which seems fair enough as it is a hack workaround) but bug is closed as the OP closed it.
  • Bug fdo#56344 is raised to address same issue. This bug is still unconfirmed. A temporary patch was offered to fix the issue, but not merged into master.
  • In comment #33 of LP#1020048 an alternative workaround is suggested: switch LO to use the system Print dialog (Tools > Options… > General > Print dialogs > uncheck Use LibreOffice dialogs). The OP of the question here appears to be using system dialogs anyway.
  • In comment #34 of LP#1020048 it is announced that CUPS v1.6.2 is released and this timeout issue with LO appears to have been specifically addressed.

I have a brother printer and I am using this printer from last 2 years this is good but now I am expressing a silly issue that is when I am printing this device showing Brother Printer error code 2147500037. How can I remove this error? What should I do? PLZ help!!!