[Solved]Writer only prints a tiny document at the top left of page.

The print preview and print dialog box both show the document as A4 or Letter, but it prints about 50mm x 65mm. I’ve tried adjusting page size in both the Format/Page dialog and the Print dialog. If I export to pdf, the pdf is fine and prints fine.

You can download the document, and here’s a scanned picture of the print out:

I’m using:

  • Version: 6.1.1.2
  • Build ID: 1:6.1.1-1
  • CPU threads: 4; OS: Linux 4.17; UI render: default; VCL: gtk2;
  • Locale: en-US (en_US.utf8); Calc: group threaded

If it matters, Linux is fully up-to-date Debian Testing. My printer is an Epson L605. It prints fine with all other applications.


Thanks for the fairly full details. Would it be worth adding information about your printer? My (Ubuntu) experience is that printer drivers can be give quite variable support for the hardware…

Updated to include printer details. Thanks @dajare

@lilgman - what about the “General” tab > [Printer] Propherties"? This is what mine looks like. Since you’re on Linux, can you check your printer reports? I can get this via a web interface, http://localhost:631/ to get to the CUPS information (assuming you have CUPS installed).

@dajare I added a screenshot of the “General” tab. It’s a little different than yours, but not much. I’ve tried clicking and unclicking the “Use only paper size from printer preferences,” but the results are the same–still small. I’ve also looked at my CUPS setting, but don’t see anything out of order there. Also other apps are printing fine.

@lilgman - I tried recreating your document on my system. I uploaded the ODT and PDF which you can grab and check if you like. The font I used is Andika New Basic, which I find works well in such documents (scroll down for the “New Basic” version which has the full “family” of styles). I doubt it will make a difference, but worth crossing off another variable?

Also, there is an Epson-related printing problem in the Document Foundation bug-tracker, quite recent, which has some resonances with your issue (printing from LibO results in unexpectedly small print; PDF of same document prints fine). Worth investigating?

I discovered something new about this problem. If I print using a USB cable instead of the network printer, it prints fine. I think I’ll delete and reinstall the network printer.

@lilgman - I’ve been wondering how it’s going. :wink: Glad you’re making progress!

I’ve been away a lot, and just finally got around to deleting and reinstalling this printer. I’ll have to test more to be certain, but the sample document now prints correctly. I’m assuming this was a CUPS/printer installation problem, though I don’t know what it was for sure yet. Initially I was able to print (some?) PDF files with no problems leading me to assume this was a LibreOffice problem. Later (some?) PDF files also did not print correctly. I’m marking this solved. Thanks @dajare!

Look like your printer is configured to print 32 pages on a page. Scan your printer options and set it to 1 on 1.

I don’t believe so. I’m posting a screen shot of the settings to the original. Thanks for the suggestion, however.

The first screenshot is writer, and the second screenshot ist Calc? There is no match.

My apologies. They are both writer documents, but different ones. I’ve uploaded the correct screenshot now.

Delete and reinstall network printer using Printer Setting gui or other utility.