Some system fonts not loading

I am on win10/64 and have numerous fonts which have been installed using the windows system font installer, so they are installed in the default font directory. When I try to override any format, even standard, with some fonts they do not appeared to have been loaded into LibreOffice and instead it displays a default Arial or some other garbage font instead. Why? It works in AOO4.1.x, why not LO6.5.x? Since a pic is worth a 1000 words, here is a side-by-side compare, same file, same location.

As you can see in the font window, Sütterlin, size 12 is clearly chosen.

Thoughts? Suggestions? I have already reloaded the font into the system, it clearly is being picked up on AOO and other Apps mind you, is there something special I have to do in LO?

Some additional information, since some have asked. It is a TrueType (version 1) font and if I pulldown in the font menu it does show the correct font face, see below.

image description

And per the properties of the font…to be unambiguous.

image description

The workaround for now is to bring up my file in Apache OpenOffice, where it renders, and take screenshots. Then after some image modifications pull what I need in as images.

If anyone is interested, the TTF file can be downloaded here to confirm my issue.

What are the technical properties of the Sütterlin font? Is is a TrueType font? A Type 1 Adobe font? Is it a widely available font (meaning it has been converted to recent font technologies)?

This is important because the font renderer in LO changed in the past years and support for some older font technologies has been dropped.

@ajlittoz - wouldn’t the font name appear italic (Sütterlin) in the font name box, if it was a Type 1 Adobe font and thus not available at all? (just for my curiosity)

@anon73440385: the italic decoration is for missing fonts. I tried to check with an old document of mine, but the Type 1 font I used was a system font (Linux distro: Nimbus Roman No9 L) and is no longer installed not downloadable. I can’t then verify if Type 1 installed but not manageable are also displayed with italics in the Font box.

Before sending this comment, I happened to find a type 1 font on my computer. I installed it and it does not show in the Writer list. If I force the name (but not sure if it behaves exactly like a valid selection), name show as italics. On OP screenshot, name is Roman style, so I can’t tell.

See my updated issue above for some of the answers to your comments.

TrueType and Type 1 are two different formats. TrueType may have versions but writing TrueType-1 is ambiguous. Nevertheless, my lead may be wrong because “Sütterlin” is not displayed in italics in the font box. This means Writer has detected the font and can manage it.

Check if a replacement table is active. Go to Tools>Options, LibreOffice>Fonts. See if some font is substituted for Sütterlin.

I looked at that, the replacement font options, no it is not active and I saw no reason to try it either. IMHO, it’s a bug, but I could be wrong.

The link you provided is only a screenshot of some description of the font. Where can I download it?

The font screenshot shows that the glyphs have been stored at U+F0000 as some sort of ISO-8859 offset by 0xF000 (starting at 0xF020 for space and extending up to 0xF0FF). This is within “Private use” area of the Basic Multilingual Plane in Unicode.

I don’t know if there are special tables in the Sütterlin font so that when you type some ASCII or Latin-1 character it is automatically offset to the corresponding U+F0xx character. This is surely unusual and may explain why Writer does not interpret correctly the font (non-standard font tables?). I suppose you enter your text as usual without any keyboard or Unicode trick.

Anyway, I’d like to have a try here.

OK, I have zipped up the ttf file and uploaded, new link is above.

As for your other question, yes, I just select the font and type as usual, no unusual key strokes needed, except of course when needing special characters, like ä, then I use ctrl-alt-q for that, etc… I am using a standard english keyboard with eng-intl win10 setting while typing.

LanguageTag     : de-DE
Autonym         : Deutsch (Deutschland)
EnglishName     : German
LocalizedName   : Deutsch (Deutschland)
ScriptName      : Lateinisch
InputMethodTips : {0407:00000409}
Spellchecking   : True
Handwriting     : False

LanguageTag     : en-US
Autonym         : English (United States)
EnglishName     : English
LocalizedName   : Englisch (Vereinigte Staaten)
ScriptName      : Lateinisch
InputMethodTips : {0409:00020409, 0409:00000409}
Spellchecking   : True
Handwriting     : False

Your Google drive is protected. Send me a private email at ajlittoz (at) users (dot) sourceforge (dot) net with the zip file in an attachement.

Sent to you a direct link via email, that should work and an email with the zip file, just in case.

Die Antwort vom Remoteserver ist:

550 Blacklisted file extension detected 

I guess zip files are not allowed. Did the link work? I will try to send the ttf file…but am not hopeful.

The problem is in the Sütterlin font.

I opened it with FontForge and I immediately got warnings and errors. Minor warnings are about discrepancies in copyright notice and various names between Mac and Windows table entries (since these are rather comments, they can be ignored).

More serious “errors” involved the dictionary of glyph name and their encoding. This is how I interpret them.

The font is copyrighted 1995 to R. G. Arens. At that time, Unicode was not yet universally adopted by all OSes and computers. It is then likely this is an 8-bit font in ISO-8859-like encoding (the famous Windows page codes).

This suspicion is confirmed by the fact that the font contains less than 256 glyphs (max capacity in 8 bits minus the C0 and DEL controls which are omitted). What makes me confident in this guess is that the C1 controls series has been used to stuff more graphic characters because the standard areas 0x20-0x7E and 0xA0-0xFE were already full. The encoding led to a name in the dictionary (and reciprocally) which in turn provides a pointer to the glyph (for rendering).

This font has been “Unicode-ised” in a quick’n’dirty way. The Unicode dictionary (like SPACE or LATIN CAPITAL LETTER A) has been tweaked so that SPACE is no longer associated with U+0020 but with U+F020 (and so forth for the other characters). The normal behaviour of any font rendering engine is to use a character in some adequately font for missing glyphs (Serif or Sans families according to the advertisement in the font tables). Thus you type Russian text while in Sütterlin and get Cyrillic letters.

Unfortunately, the dictionary offsetting for “standard” characters seems to be an unsupported practice. FontForge warns against this dictionary abuse and very likely not all font renderers can manage such non-conforming font. I suppose that the one used in AOO preprocesses the font so that the glyph at U+F020 which is referred to with the SPACE name is in fact repositioned to the standard SPACE index of U+0020.

Strangely enough, the U+F000 to U+F0FF private use area is qualified “Microsoft Symbol Area” by FontForge when editing this font.

I don’t think there is a bug in LO, nor in its font engine (Harfbuzz?) when presented such a distorted font.

I suggest you contact Herr Arens if you can to ask him to change his font to some more conformant encoding. Only a few “extra” characters should be sent to the private use area (only those which cannot be considered as a graphical variant of the corresponding LATIN [CAPITAL] LETTER x like long-s (or round-s if preferred) so that you type with the usual keyboard to encode the usual letter, the font being responsible only for the shape).

Another fix would be to use a font editor (like FontForge under Linux) to reallocate the glyphs in ASCII and Latin-1 areas. I have tested it, it works. However, before doing this task, you must think about the glyphs which have been allocated to the C1 range (0x80-0x9F). These are strictly controls in Unicode and can’t be used for displayable shapes. They must be allocated to available locations in Unicode, probably in private use areas. This means you must carefully plan this because it involves maybe not-so-user-friendly typing sequence to access them. This may also break already typed tetx.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

Thank you for a thorough explanation of what is going on. I will consider your comments about editing after I have performed my workaround in the rest of my document so I can move forward.