sort of xls file hangs

I have a .xls spreadsheet that I have been updating monthly using OpenOffice. I just installed Linux 6.7 and with it came LibreOffice instead of OpenOffice. LibreOffice will NOT sort this spreadheet. My screen goes gray and then an hour later I have to force shutdown the program. This is a monthly process that I need to complete ASAP. Can you help me get this spreadsheet sorted? Please? Thanks, Bonnie

i am using the menu bar. selecting ‘Data’ then ‘Sort’

Hi cobonnie

It is possible to install AOO & LO in tandem.

That .xls file needs to be saved in native AOO/LO format (.ods) - both AOO & LO will be able to open those files. XLS is far more problematical due to differing standards of compatibility with MS. If you need to later transfer it to someone running M$ Office you can then save in XLS format.


If this helps then please tick the answer (:heavy_check_mark:)

…and/or show you like it with an uptick ()

I saved my .xls file as a .ods file and the sort still hangs. my it support has tried to install OpenOffice but get an error saying there is a file conflict. We even tried removing LibreOffice and installing OpenOffice but again we got an error saying there is a file conflict. Evidently LibreOffice cannot be removed (?). Transaction Check Error:
file /usr/bin/soffice from install of ibm-config-openoffice-1:4.1.1-9775.el6.6.x86_64 conflicts with file from package libreoffice-core-1:

“LibreOffice cannot be removed”: nonsense. “Transaction Check Error”: evidently LO is NOT uninstalled. Good job, IT Support.