Sorting by columns

suddenly it won’t sort by columns on my spreadsheet. msg says “Ranges containing merged cells can only be sorted without formats.” But I don’t have any merged cells! Must have inadvertently clicked something, but what ?

If you ‘Select All’ and get ‘Split Cells’ offered in the context menu of the huge selection, you actually have merged ranges in the sheet, whetehr created advertently or otherwise.

Accepting the 'Split Cellś option should cure the issue then.

Thanks Lupp; "split Cells’ fixed my problem but I don’t understand how some parts of your answer really apply.

  • ‘Select all’ is not appropriate: My selection for sorting excludes the merged cells at the head of my spreadsheet.
  • I don’t see a context menu associated with my selection.
  • There are no merged cells in my selection; none. But I still get the error message.

I got rid of the message and sorting worked once I found the location of ‘split cells.’ It’s in the menu Format under Merge Cells (!). So my problem appears to be solved but I would like to understand how it arose. (Clicking on ‘split cells’ seemed to have no visible effect on my spreadsheet.)

Can you (anyone) suggest what the real problem might have been?

“Can you (anyone) suggest what the real problem might have been?”
Not without the file, I’m afraid.
What is your version?. For a very long time now I get ‘Merge Cells’ in the context menu opening on RightClick in a selected range. ‘Split’ is only offered if merged areas are selected.

I’m using linux mint 17. What’s your OS?

LibreOffice version:; Build ID: 420m0 (Build:2). It’s the repository version for this mint release.

Understandable that you can’t diagnose without the file! I just wondered if there’s a common trap folks fall into without realizing.

If I remember correctly 4.2.8 had some flaws.
Current Version is 6.1.3. Strictly sticking to dedicated repositories may come with some disadvantages, but I cannot tell you which younger versions support your OS. Mine is (sadly) Win 10. And I use and test lots of LibO versions.