Special characters inserting out of order as I type?

When I insert special characters whose ALT + number includes the number 4 (such as alt + 0234 which is the ê, or alt + 0241 which is the ñ, or alt + 0243 which is the ó), the characters are inserted BEFORE the previous letter. This is not happening in any other program, just LibreOffice. For example, when I try to type “español”, it comes out “espñola”, or when I try to type “voçê”, it comes out as “voêç” (inserting the ê before the ç). This happens whether my keyboard is set to English, Spanish, or Portuguese. I’ve tried turning “numlock” off and on again, with the same results.

Could my settings be somehow off? Any help would be appreciated. I’m very new to LibreOffice.

You’re also new on this site. Please mention OS name (Windows, I guess because of your use of Alt+decimal, but which version?), LO version and save format.

You are on the right track but you have your on and off incorrect. If NumLock is turned off then the arrow keys come into play so your character is entered but the arrow key moves it. The NumLock should show a locked padlock to work.

I can reproduce the effect if I turn the NumLock to off (unlocked) as shown below

Libre Office 7.6 (just dowloaded it today, I believe the newest version).
Windows 11, 64-bit.
If I understand what a “save format” is, this issue is happening whether I’ve got the document set to save as .odt, .docx, or .rtf. I haven’t tried any other types of documents yet. Does this answer your questions?

So that’s what I thought at first too. But then when I press the Numlock key again and try, LibreOffice opens a series of menus instead of typing a character. I’m trying to upload a screenshot; hopefully it works!

Thanks for helping this rookie out!!

The important thing is that the Alt numbers are Windows only. The usual method is to write the Unicode number then immediately press Alt+X,
Version 7.6 has been modified, please see this question here to change the keyboard shortcuts if you want to continue using Alt+numbers , [regression] cannot enter alt+number codes for unicode symbols anymore after updating to LibreOffice

1 Like

This answer is so helpful, and it is working for some letters but I’ve got a followup question to make sure I truly under the solution.

Using the unicode, am I always required to use the u+ before the number? Why does it sometimes work and sometimes not without the “u+”? Example screenshot below

I ask because using the u+ slows me down. If I have to use it, that’s ok, but I’d prefer to just be able to use the unicode digits since that’s faster. (words per minute is much slower when I have to type u+00f1 and then alt+x all the time)

If the Unicode number is unambiguous, then the U+ and leading 0’s can be omitted. In your example of español, then the whole code must be written, but to write just ñ by itself, then f1 then Alt+X will work. The letters abcdef will add themselves to the unicode number unless separated by the U+

There is no real loss in removing the newly added keyboard shortcuts, they aren’t essential and the process is relatively quick to undertake.

Thank you so much for this tip! I’ll see how I do with the unicode, and if I don’t get as fast as I want to at typing, then I’ll look into removing the newly added keyboard shortcuts. I’ll try to change my human input before changing the way the program works. I’ll return to these conversations if I have difficulty moving forward re: this issue. Thanks a bajillion!

You can select the f1 after espa (and Alt+X) to get españ, otherwise af1 will be converted.

1 Like

Interesting factoid: Word does not insert Alt+Numpad characters without NumLock; in this case, Alt also disables arrow movement. OTOH, WordPad still allows to insert these; and arrow movement is also disabled with Alt. So - it would be nice to file a report about this, and disable the movement when Alt is pressed.


Bug 159079 - With NumLock off in Numpad, then with Alt pressed the Num Pad arrow keys should not operate.

Fix will be available 24.8
Now 24.2.1