Spectral Light font not loading correctly in 7.5

Edit: It seems only one of my .odt files is unaffected, and I have no idea why.
Edit II: It seems the problem has gone back to just affecting .docx files. Sorry for so many edits! This is all very confusing. I’ll keep people updated if things change ^^
Edit III: Third edit in a row, oh boy. So it seems that if I open an affected .docx file and try to edit an existing .odt file or create and use a new .odt file with Spectral Light, the number/punctuation/symbol errors occur. The new solution I’m currently doing is changing the fonts in my .docx files, then creating a new .odt file and putting said content there. Tedious, but manageable. If there’s a better way to handle this, feel free to let me know. I could sure use it.

Hi! I’m not very tech savvy, so please bear with me. You may have to explain things like how you’d explain them to your mom or your grandma. (I’m a new user too, so it’s not letting me embed all the screenshots I took.)

This morning I updated from 7.4.7 to 7.5.6. I forgot to close out LibreOffice, so I had to do so during mid update. I noticed that when it was replacing the fonts, the update slowed significantly, and then picked back up when it was finishing everything else. I restarted my computer, and when I opened up one of my old .docx files, I was greeted with a nasty surprise.

I uploaded the .docx file to Google Docs and it was readable, so the files were not corrupted. I reinstalled the entire Spectral font family without uninstalling it first, and it actually fixed it. Well, a little bit anyway.

All numbers, basic punctuation, and other symbols (e.g. em dash) were instead replaced by weird Latin characters with diacritics. I tried opening one of my .odt files to see if this was just a .docx compatibility issue, but the error was occurring with my .odt files as well.

I proceeded to completely uninstall both the Spectral and Spectral SC family from my computer, then reinstall both fonts. On my .odt files, it was fixed; all non-Latin characters were showing up as they were supposed to. However, whenever I opened a .docx file, the non-Latin characters would show up as the weird gibberish again. I then proceed to open the same .odt file that appeared to be fixed, and that too had reverted back to its weird punctuation/number gibberish. Whenever I opened an affected .docx file, the errors would reappear in previously fixed .odt files. I have noticed that this error only occurs with Spectral Light specifically, and not any other Spectral fonts.

At this point, I’m considering uninstalling the Spectral family, converting all of my .docx files to .odt files (which I probably should’ve done, but wahhh I’m lazy), then reinstalling the font family. But that takes a long time, and I also happen to be migrating everything from Google Docs to LibreOffice, and much of my work is in Spectral Light. I want to know if there happens to be an easier solution, or at least what is causing LibreOffice to butcher Spectral Light, and why if I open an affected .docx file, it affects my .odt files. I’m also considering uninstalling and reinstalling LibreOffice to see if that will fix anything.

It is not bad if you have little experience. Experience is only possible when you do something.
And you have the experience that it is not good to change from ODT to DOCX.
This is exactly what the reality reflects.
Here you can learn why these problems exist and what you can do about them:


And if you really want to switch completely to LibreOffice (congratulations for that), you should also read this:

My Transition from MS-Office to LibreOffice

Then, if you still have questions, ask them here at English - Ask LibreOffice.

Try closing LibreOffice and run the installer, but this time choose Repair.

Thanks for replying! I ran the repair and opened a random .docx file, and the error with the font still occurred unfortunately.

Thank you for all the links!

I see that the language for your document is set to Japanese. Does the text contain Japanese characters or Western characters?
Can you post a sample document?

IMHO the user-profile is more often causing trouble than installation, and this profile is NOT changed during re-install.
So my next step would be to try safe-mode or renaming my profile.

The other is uploading one of your “affected .docx” here, to find out, if this is a general problem or in your installation.
Could you also tell, wich OS you use? Win11?

1 Like

The text in that specific document contained purely Western/Latin characters. The .docx files are set to Japanese because when I was using Google Docs, I had the language set to Japanese so the autocorrect wouldn’t be unbearable. All of my .odt files are set to English (USA).

Earlier I did test to see if Japanese characters were affected, and they were not (thankfully), even when they were in Spectral Light.

Here is a sample document.
sample document ii.docx (8.0 KB)

(It’s the right document now lol).

Sorry! I forgot to mention the OS I use, and it is Windows 11. I’ll try tinkering with the user profile and safe-mode to see if anything changes.

Okay so some interesting things I noticed while I was struggling to produce a sample document.

If I create a copy of an affected .docx, all of the punctuation, numbers, and other symbols are fixed and legible. The same thing happens if I send the document to the recycling bin, and then restore it. I think I may have solved my own problem lol.

Edit I: Spoke too soon, it seems these .docx files are now acting like the .odt files, which rely on whether or not I have an affected .docx file open. But it’s still progress.

It’ll be several days before I am in front of a computer.

Follow @Wanderer suggestion to see if issue exists in safe mode. Click Help - Restart in safe mode - Continue in safe mode and test your documents. If everything is OK then it would be a problem with your user profile, see LibreOffice user profile - The Document Foundation Wiki

I got home unexpectedly soon. Your file looks OK except for the splitting of words where the line fell instead of hyphenating them properly which is result of setting language to Japanese. Also the empty paragraphs instead of proper paragraph spacing is poor practice.

So check your user profile