Spell check does not work

i use libreoffice 7, with english(usa) or english(uk) but the spell check never seems to work
i have created quite a few documents from libre writer they had some typing errors that i noticed later but librewriter did not highlight or auto corrected them

is there something i can do to make it working
i use manjaro kde, if at all that helps somehow

any help will be appreciated

i use manjaro kde

… and you most probably use LibreOffice from Manjaro’s package manager pacman - right?

  1. Read this tutorial.
  2. If you can’t find an answer, read these guidelines and ask a good question.

ya i use pacman


assure you have installed:

  • hunspell-en_GB
  • hunspell-en_US

( Installation in a terminal by: sudo pacman --sync hunspell-en_US hunspell-en_GB)

and your text is set to one of these languages.

Just tested on Manjaro (updates as of today) and using

Version: / LibreOffice Community Build ID: 10(Build:3)
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: kf5
Locale: en-US (de_DE.UTF-8); UI: en-US, 7.1.0-1, Calc: threaded

thats already installed

Additionally my answer stated:

… and your text is set to one of these languages.

Text elements in Writer (paragraphs, words) can have different languages. Hence you need to assure that the text elements have the proper language settings. LibreOffice does not detect the language automatically. Example: If using a German environment (all LibreOffice settings being German (Germany)) and I’d like to correctly spellcheck an English paragraph, I need to set the paragraph to English (US) or Englisch (UK).

If that does not work (and on my Manjaro that works), please upload a sample file, where you have errors and which won’t get marked as such.

Please do **not** use *Add Answer* but **[edit](https://ask.libreoffice.org/t/spell-check-does-not-work/61778)** your original question to enhance the details of your question and/or to upload sample file(s) (answers are reserved for solutions to a problem on this Q&A site). Thanks in advance …