Spell check non functional

Phew! Right - got it.
The side bar was showing properties rather than styles, but now I located this settings area. Language says UK, so seems ok?