Spell check non functional

I cant seem to get the spellcheck to do anything, it doesn’t find misspelled words & it doesn’t highlight anything. Ive looked through the settings & cant see why this would be. I’m quite stuck as how to proceed.

I’m using Libre Office writer Ver 7.3, on Manjaro 21.2 Gnome 41.3

  • In LibreOffice Writer TOOLS > Automatic spelling is Ticked.
  • In TOOLS >Spelling … the pop-up window says Text Language [NONE] I can change it to USA, but it will always go back to none.
  • No words or suggestions show up in this window.
  • When I go into the OPTIONS button, there are several dictionaries listed & ticked, including US, GB, standard, technical. The ‘check as I type’ option is also enabled here as well as ‘check grammar’ & a few others.

Which means that the actual text language is, yes, none. To change the text language, select the text and use the language selector in the status bar (the lowest part of the window). Or use styles.

The language is already selected as English in the status bar.

Screenshot from 2022-02-24 12-42-42

oh but I have found a clue! thanks to your idea. ~ I selected all text & changed to the USA language & then the spell check worked.
Is there some way to get this to work with standard English?

What do you mean under standard English? I have never heard of such thing.

Yes, make sure that you have a dictionary installed for standard English, whatever that is, then do the same as with US English. It’s better, though, if your text is in English, to set the language to English in the default paragraph style (Font tab), then your entire text will be English without any more effort.

1 Like

What do you call “standard English”?
LO Writer comes out-of-the-factory configured for US English. To enable spell-checking for other variants, you need to install a package names libreoffice-langpack-en (Fedora package name, may be different under Manjaro).
To create documents under a specific English variant by default, you must configure it in Tools>Options, Language Settings>Languages and choose one in drop-dow menu Default Languages for Documents: Western:. The languages with an A-like icon are those for which spell-checking is enabled.

I think I have the correct settings, but it doesn’t seem to work unless I use US English.
Can you see any problem with this?

& the writing aids option. Default Language is UK English & new Documents start as that - but the spell check doesnt work still unless I change language spelling variation to USA.

Schermafdruk van 2022-02-24 14-15-11
Check mark missing. You need to get that dictionary before you can use it.

1 Like

Sorry, I mean the standard English spelling, such as Colour. The US version will highlight my correct spelling as incorrect in this case.

[off-topic] You mean standard UK spelling. But the standard in the UK is not the standard in the USA, Australia, New Zealand and many other countries.[/off-topic]

Then you may have botched several settings which take effect after those in Tools>Options. For instance, you could have changed the default template which is implicitly loaded at start up to “patch” the styles. Have a look at Default Paragraph Style, Font tab. If you read Language: [None], you definitely damaged the default template.

You can fix the situation for the current document by pressing the Reset to Parent button. Fixing for all future documents requires to restore the default template to its factory state. You could have a try with Help>Restart in Safe Mode. We’ll give you instructions for permanent reset if this works.

Excellent! Thank you - this fixed it.

For anyone else struggling with this under TOOLS > Spelling… [options] you can find a link to “get more dictionaries online” & in that list is one simply called ‘English’ which you can install.

WARNING! If you install LO with your distro package manager, you should continue to use it. As I already mentioned, many English variant dictionaries are stored in package libreoffice-langpack-en. If you install through the link you mentioned, you’re mixing manual and managed installation which could cause trouble on update.

1 Like

ok, thanks for this extra detail.
I didn’t see your reply at the time as I was investigating floris_v’s post about installing dictionary. I was searching for a way to do that in the software & I was trying to be proactive to find the answer myself.

Nevertheless, after now checking pamac for ‘libreoffice’ the only results are the main LO apps & I see no other packages related.

For a quick query on the net, I see Manjaro is based on Arch Linux. The Manjaro site describes package libreoffice-fresh and libreoffice-en-US. Then it seems you can’t install other language pack from the official repo. IMHO, this is a weakness compared to other distros.
You are doomed to install any other LO component from the official site but the distro maintainers may have chosen to host the package files in directories different from those designated in the official site. You’ll have to inquire by yourself to make a “compatible” installation.

Sorry, I am struggling to follow this. Im not sure if I located ‘Font tab’ correctly.
Is this TOOLS> Options >Libre Office > Fonts?
I also dont see ‘reset to parent’ anywhere.

It maybe better for me just to leave this as is & come back if something is broke. There are so many options & menus digging into this I am getting quickly overwhelmed.
I appreciate the help so far & it seems like the spell checker is working now.

Display the side style pane with F11 if not already visible. Right-click on Default Paragraph Style and select Modify (thanks @floris_v for noting the missing bit), then go to the Font tab.

Right click that style and select Modify.