Spell check not working in on Linux

As the title says the spell checker in LOff on Linux (RHEL6.3 x86_64) does not function at all. With words that are definitely misspelled in a short text document, when I use the spellchecker from the tools menu it says the spell check has completed without errors. I expect better quality from LibreOffice than this.

Take a look, if you can find help in this thread:

I have read through all of the stuff in that web page entry but nothing seems applicable here.

I just checked and I have the following installed:

libreoffice3.6-dict-en.x86_64 0:

This is the only dictionary rpm I have installed. I tried re-installing this but it made no difference.

When I go to Tools->Language->For all Text I cannot select a language and there are no check marks next to any ones listed there.

Under Options->Language Settings->Writing Aids I see an entry for the following dictionaries: Standard [All], Slovenian, technical [All], en-GB [English UK], en-US [English USA], and IgnoreAllList [All]. I currently have a check mark next to Standard [All], en-US, and IgnoreAllList [All]. I can uncheck Standard [All] and en-US but I am not able to uncheck IgnoreAllList.

I do know that when I try to do a spellcheck there are no dictionaries shown in the spellcheck popup window.

OK, I just solved this. I tried re-installing a bunch of the rpms for but nothing seemed to do the trick until I discovered I did not have the libobasis3.6-ooolinguistic rpm installed. Once I installed that, the spell checker started functioning. Why isn’t this a dependency of some of the other RPMs if it is required to have a functioning spell checker???